PROBLEM

Benutzeroberfläche der Anmeldeseite für Portal for ArcGIS wird in Chrome nicht angezeigt

Last Published: April 25, 2020

Beschreibung

Wenn zum Anmelden bei einem ArcGIS-Portal Chrome verwendet wird, wird der Abschnitt zum Anmelden nicht angezeigt. Stattdessen ist ein beschädigtes Webelement zu sehen.

Image of the missing element
Hinweis:
Um zu prüfen, ob folgender Fehler vorliegt, öffnen Sie die Entwicklerwerkzeuge von Chrome (F12), um die Konsole zu überprüfen. Auf der Registerkarte "Console" sollte eine Fehlermeldung angezeigt werden, die besagt, dass der Abschnitt der Benutzeroberfläche aufgrund von "X-Frame-Options" nicht angezeigt werden kann.

Ursache

Dieses Problem tritt auf, wenn der Wert für den "X-Frame-Options"-Header in Web Adaptor auf SAMEORIGIN festgelegt ist.

Lösung oder Problemumgehung

Führen Sie zum Beheben des Problems auf dem Computer, auf dem Web Adaptor installiert ist, folgende Schritte durch:
  1. Navigieren Sie über die Windows Systemsteuerung zu "Verwaltung", und führen Sie Internetinformationsdienste-Manager (IIS) aus.
  2. Blenden Sie die Sites im linken Bereich ein, und klicken Sie auf den entsprechenden Web Adaptor des Portals.
  3. Wählen Sie im rechten Bereich unter der Kategorie "IIS" die Option HTTP-Antwortheader aus.
  4. Doppelklicken Sie auf den Header X-Frame-Options.
  5. Ersetzen Sie die Werte in diesem Feld durch Folgendes:
ALLOW-FROM https://portal.domain/webadaptor
  1. Klicken Sie auf OK.
  2. Öffnen Sie Chrome, und navigieren Sie zur Anmeldeseite, um zu prüfen, ob das Anmeldeseite-Element geladen wird.

Artikel-ID:000019542

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden