Deutsch

How To: Konvertieren von Shapefile-Polygonen in Polylinien

Zusammenfassung

Die Konvertierung von Polygonen in Polylinien (und umgekehrt) ist bei der Kartenerstellung und Analyse ein nützlicher Workflow in ArcGIS. Aus allen gemeinsamen Grenzen wird ein Liniensegment und aus nicht gemeinsamen Grenzen ein anderes Segment. In diesem Artikel werden Polygone in Polylinien konvertiert, indem sie kopiert und in ein Polylinien-Shapefile eingefügt werden.

Hinweis:
Polygone können mit den Werkzeugen Polygon in Linie und Feature in Linie in Polylinien konvertiert werden. Diese Werkzeuge sind nur mit der ArcGIS Desktop Advanced-Lizenz verfügbar.

Vorgehensweise

Im Folgenden werden die Schritte zum Konvertieren von Polygonen in Polylinien in ArcMap oder ArcGIS Pro beschrieben:

Hinweis:
In ArcMap und ArcGIS Pro müssen die Polygon- und Polylinien-Shapefiles bzw. die Polygon- und Polyline-Feature-Classes im selben Verzeichnis gespeichert werden, damit Features kopiert und eingefügt werden können.
In ArcMap:
  1. Fügen Sie der Karte das Polygon-Shapefile hinzu.
  2. Navigieren Sie in ArcToolbox zu Data Management Tools > Feature-Class > Feature-Class erstellen.
  3. Geben Sie im Feld Feature-Class-Speicherort im Dialogfeld Feature-Class erstellen die Ausgabe-Geodatabase oder den Ordner für die Polygon-Feature-Class an.
  4. Legen Sie für Name der Feature-Class einen Namen fest.
  5. Wählen Sie für Geometrietyp die Option Polylinie aus.
  6. Wählen Sie in Template-Feature-Class das Polygon-Shapefile aus.
  7. Wählen Sie für die Felder Hat M und Hat Z die Option SAME_AS_TEMPLATE aus.
  8. Wählen Sie für Koordinatensystem das Koordinatensystem des Polygon-Shapefiles aus, und klicken Sie auf OK.

    Create Feature Class dialog box

    Das neue Polylinien-Shapefile wird erstellt und im Inhaltsverzeichnis angezeigt.
  9. Starten Sie eine Editiersitzung, um die Shapefiles zu bearbeiten.
  10. Klicken Sie im Inhaltsverzeichnis mit der rechten Maustaste auf das Polygon-Shapefile, und klicken Sie dann auf Attributtabelle öffnen.
  11. Klicken Sie in der Attributtabelle auf Tabellenoptionen > Alle auswählen.

    Select all features in the attribute table
     
  12. Wählen Sie in der Werkzeugleiste Editor das Werkzeug "Editieren" aus.

    The Edit Tool
     
  13. Klicken Sie im Kartenrahmen mit der rechten Maustaste auf eines der ausgewählten Polygon-Features, und klicken Sie dann auf Kopieren.

    Copy all the features
     
  14. Klicken Sie erneut mit der rechten Maustaste auf die ausgewählten Features, und klicken Sie dann auf Einfügen.
  15. Wählen Sie im Dialogfeld Einfügen das Polylinien-Shapefile als Ziel aus, und klicken Sie auf OK.

    Paste dialog box
     
  16. Speichern Sie die Änderungen, und beenden Sie die Editiersitzung.
  17. Das Polygon-Shapefile wird in ein Polylinien-Shapefile konvertiert, und alle Attribute werden beibehalten.

    Polyline shapefile is created

In ArcGIS Pro:
  1. Klicken Sie auf der Registerkarte Analyse auf das Symbol Werkzeuge in der Gruppe Geoverarbeitung, um den Bereich Geoverarbeitung zu aktivieren.
  2. Navigieren Sie zu Toolboxes > Data Management Tools > Feature-Class > Feature-Class erstellen.
  3. Geben Sie im Feld Feature-Class-Speicherort im Dialogfeld Feature-Class erstellen die Ausgabe-Geodatabase oder den Ordner für die Polygon-Feature-Class an.
  4. Legen Sie für Name der Feature-Class einen Namen fest.
  5. Wählen Sie für Geometrietyp die Option Polylinie aus.
  6. Wählen Sie in Template-Feature-Class das Polygon-Shapefile aus.
  7. Wählen Sie für die Felder Hat M und Hat Z die Option Entspricht der Template-Feature-Class aus.
  8. Wählen Sie für das Koordinatensystem das Polygon-Shapefile im Dropdown-Feld aus, und klicken Sie auf Ausführen.

    Create Feature Class toolbox
     
  9. Das neue Polylinien-Shapefile wird erstellt und im Bereich Inhalt angezeigt.
  10. Klicken Sie auf der Registerkarte Inhalt mit der rechten Maustaste auf das Polygon-Shapefile, und klicken Sie dann auf Attributtabelle.
  11. Klicken Sie auf der Registerkarte Ansicht der Attributtabelle in der Gruppe Auswahl auf Alle, um alle Features im Karten-Layer auszuwählen.

    In the View tab for the Table, in the Selection group, click All.
     
  12. Klicken Sie mit der rechten Maustaste auf eines der Features, und wählen Sie Kopieren aus. Ein Ladefenster wird kurz angezeigt.
  13. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Zwischenablage im Dropdown-Feld auf Einfügen, und wählen Sie Inhalte einfügen aus.

    Paste Special option
     
  14. Wählen Sie im Dialogfeld Inhalte einfügen die Option Vorlage und dann das erstellte Polylinien-Shapefile aus.
  15. Aktivieren Sie das Kontrollkästchen Quellattributwerte beibehalten, um das Quellattribut aus dem Polygon-Shapefile zu übertragen, und klicken Sie auf OK.

    Paste Special dialog box
     
  16. Das Polygon-Shapefile wird in ein Polylinien-Shapefile konvertiert, und alle Attribute werden beibehalten.

    Polygon shapefile is converted to polyline shapefile

Referenzinformationen