PROBLEM

Meldung der Kategorie SEVERE im Serverprotokoll mit lediglich AvailableFonts als Beschreibung im Zusammenhang mit dem Service PublishingTools

Last Published: April 25, 2020

Beschreibung

Versuche zum Veröffentlichen von Services schlagen mit der Fehlermeldung "Das Paket wurde erfolgreich erstellt, es konnte jedoch nicht veröffentlicht werden" fehl, und im Serverprotokoll wird die folgende Meldung der Kategorie SEVERE aufgezeichnet: "AvailableFonts". Diese Meldung steht im Zusammenhang mit der System/PublishingTools.GPServer-Meldung. Die folgende Abbildung zeigt ein Beispiel für die Protokollmeldung.

The image of the SEVERE log message.

Ursache

Dieses Problem weist darauf hin, dass AvailableFonts-HTML- und XML-Dateien, die durch die Methode PublishingTools referenziert werden, im PublishingTools-Ordner auf dem Computer mit der aktiven ArcGIS Server-Instanz fehlen.

Um zu überprüfen, ob die Dateien fehlen, navigieren Sie auf dem Computer mit der ArcGIS Server-Installation zum folgenden Ordner:

C:\arcgisserver\directoried\arcgisoutput\System\PublishingTools_GPServer\System_PublishingTools
Hinweis:
Dieser Ordner enthält etwa 30 HTML- und XML-Dateien, darunter zwei AvailableFonts-Dateien.

Lösung oder Problemumgehung

Um dieses Problem zu beheben, müssen die AvailableFonts-HTML- und XML-Dateien im ArcGIS Server-Ordner ersetzt werden. Der Ordner, der diese Dateien enthält, kann von einem anderen Computer mit einer aktiven ArcGIS Server-Instanz kopiert werden. Nachdem der Ordner kopiert wurde, müssen Sie die ArcGIS-Server-Services neu starten. Die entsprechenden Anweisungen finden Sie im folgenden Dokument der Webhilfe: ArcGIS Server: Starten und Beenden von Services.

Artikel-ID:000018401

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden