Deutsch

How To: Importieren von XY-Daten in ArcMap und Konvertieren der Daten in ein Shapefile oder eine Feature-Class unter ArcMap 10.1 oder höheren Versionen

Zusammenfassung

In ArcMap (und ArcGIS Pro) können Daten im DMS-Format (Grad, Minuten, Sekunden) nicht gelesen werden. Diese müssen daher vor dem Importieren in Dezimalgrad (DD) konvertiert werden.

In den folgenden Schritten finden Sie Anweisungen, wie Sie XY-Koordinaten mit Microsoft Excel formatieren und diese Daten in ein Shapefile oder eine Geodatabase-Feature-Class in ArcMap konvertieren können.

ArcMap kann mehrere Tabellenformate lesen, darunter DBase III; DBase IV sowie .prn, .txt, .csv, .xls und .xlsx.

Seit 2003 erstellt Excel keine Dateien mehr im DBase-Format.

Vorgehensweise

  1. Damit ArcMap die Daten in der Datei richtig liest, formatieren Sie die Spalten mit den Werten für den Längengrad (X oder Ostwert) und den Breitengrad (Y oder Nordwert) in Excel als ZAHL mit mindestens acht Dezimalstellen für Daten in Dezimalgrad. Für Koordinaten in Meter oder Fuß sind 2 oder 3 Dezimalstellen ausreichend.
Die folgende Grafik zeigt die Verteilung von positiven und negativen Werten für Koordinaten mit Längengrad (X) und Breitengrad (Y) weltweit.

[O-Image] Decimal degree coordinates and signs
Hinweis:
Formatieren Sie das ID-Feld als Zahl ohne Dezimalstellen.
Formatieren Sie Längengrad und Breitengrad als Zahl mit mindestens 8 und maximal 11 Dezimalstellen.
Formatieren Sie die Höhe als Zahl mit bis zu 2 Dezimalstellen.
Formatieren Sie die Beschreibung als Text mit einer Länge bis zu 255 Zeichen.
  1. In der Ausgabedatei sind auch Beschreibungen des Inhalts der einzelnen Spalten erforderlich. Beschriften Sie die Spalten mit ID, Längengrad, Breitengrad, Höhe (falls enthalten), Beschreibung etc.
  2. Wählen Sie nach der Formatierung der Felder in der Tabelle alle Zellen in gefüllten Zeilen und Spalten aus, und navigieren Sie zu Datei > Druckbereich > Druckbereich festlegen oder Seitenlayout > Druckbereich > Druckbereich festlegen. Die genaue Position hängt von der verwendeten Excel-Version ab.
  3. Navigieren Sie zu Datei > Speichern unter, und wählen Sie ein unterstütztes Format aus den in Excel verfügbaren Optionen aus. Klicken Sie auf Ja, wenn in Excel eine Warnung angezeigt wird, dass bestimmte Formatierungen in diesem Dateiformat nicht unterstützt werden.
  4. Beenden Sie Excel. Klicken Sie auf Nein, wenn Excel Sie zum Speichern der Änderungen auffordert.

Die folgenden Schritte werden in ArcMap durchgeführt.

  1. Um ArcMap die Daten aus der formatierten Datei hinzuzufügen, wählen Sie die Schaltfläche Daten hinzufügen aus, und navigieren Sie zu dem Ordner, in dem die Tabelle mit den Koordinaten auf dem Computer gespeichert ist, wählen Sie die Datei aus, und klicken Sie auf Hinzufügen.
  2. Klicken Sie im Inhaltsverzeichnis mit der rechten Maustaste auf die Tabelle, und wählen Sie XY-Daten anzeigen aus.
    Warnung:
    ArcMap wendet das Koordinatensystem des Datenrahmens auf die XY-Daten an. Dieses Koordinatensystem ist für die Daten wahrscheinlich falsch.
    Im Knowledge Base-Artikel How To: Identifizieren des Raumbezugs, der Projektion oder des Koordinatensystems von Daten
    finden Sie weitere Informationen zum Identifizieren der Art des Koordinatensystems und zum spezifischen Koordinatensystem für Ihre Koordinatenwerte.
  3. Klicken Sie auf die Schaltfläche Bearbeiten, um das Dialogfeld Eigenschaften des Raumbezugs zu öffnen. Klicken Sie auf die Schaltfläche Auswählen, um ein Koordinatensystem für die Daten auszuwählen.
    Hinweis:
    Wenn eine Warnmeldung bezüglich des fehlenden Objekt-ID-Feldes angezeigt wird, können Sie sie einfach ignorieren und auf "OK" klicken. 
    [O-Image]
    
    Beispielsweise werden GPS-Daten meistens in Dezimalgrad oder als Breitengrad/Längengrad und damit als ein geographisches Koordinatensystem erfasst. Öffnen Sie das entsprechende Verzeichnis. Meist werden GPS-Daten mit dem WGS-1984-Datum erfasst. Öffnen Sie also den Ordner World, und wählen Sie WGS_1984.prj aus.

    Es empfiehlt sich, die Koordinatensysteminformationen der Daten aus der Datenquelle abzurufen.
  4. Klicken Sie nach der Definition der Projektion im Dialogfeld Eigenschaften des Raumbezugs auf Hinzufügen, Übernehmen und OK. Klicken Sie im Dialogfeld XY-Daten hinzufügen auf OK. Die Punkte werden als Ereignisdesign in ArcMap dargestellt. Überprüfen Sie, ob das Ereignisdesign auf andere Daten in ArcMap abgestimmt ist.
  5. Bei diesem Vorgang können die Daten auch erneut auf das Koordinatensystem des ArcMap-Datenrahmens projiziert werden. Klicken Sie auf Ansicht > Eigenschaften: Datenrahmen. Klicken Sie auf die Registerkarte Koordinatensystem, und wählen Sie die gewünschte Ausgabeprojektion für die neuen Daten aus. Um die Projektion während des Exports zu erstellen, klicken Sie mit der rechten Maustaste auf das Ereignisdesign, wählen Sie Daten > Daten exportieren aus, und ändern Sie das Optionsfeld so, dass das Koordinatensystem des Datenrahmens exportiert wird. Die Ausgabedaten werden im ausgewählten Ausgabe-Koordinatensystem erstellt.
Hinweis:
Wenn ArcMap darauf hinweist, dass das geographische Koordinatensystem nicht mit anderen Daten in der Karte übereinstimmt, navigieren Sie zu
Ansicht > Eigenschaften: Datenrahmen > Koordinatensystem, und klicken Sie auf die Schaltfläche Transformationen. Wählen Sie dann
die richtige Datumstransformation für die Transformation zwischen den Datumsangaben im ArcMap-Datenrahmen für den Bereich aus, in dem sich die Daten befinden.
Eine Liste geographischer (Datums-)Transformationen, deren Anwendungsbereiche und Genauigkeit finden Sie im folgenden Artikel: 
How To: Auswählen der richtigen geographischen (Datums-)Transformation beim Projizieren zwischen Daten.
Laden Sie im Abschnitt "Referenzinformationen" dieses Artikels die Liste der Transformationen
für die auf dem Computer installierte Version von ArcGIS Desktop herunter.
Hinweis:
Sind die Eingabekoordinaten im DMS-Format (Grad, Minuten, Sekunden), können Sie das Werkzeug "Koordinatenschreibweise konvertieren" in
ArcToolbox > Data Management Tools > Projektionen und Transformationen verwenden, um diese Werte
in Dezimalgrad (DD) zu konvertieren. Anweisungen zum Formatieren der Eingabedaten finden Sie in der Hilfe zu Werkzeug.

Referenzinformationen