ERROR

Layer kann nicht hinzugefügt werden. Fehler beim Laden des Service: 500.

Last Published: April 25, 2020

Fehlermeldung

Der Versuch, einen Szenen-Layer im Portal for ArcGIS Scene Viewer zu laden, wenn Sie einen Szenen-Layer aus Drone2Map for ArcGIS für ArcGIS Enterprise unter Windows Server 2016 freigeben, schlägt mit der folgenden Fehlermeldung fehl:

Error: 
Layer kann nicht hinzugefügt werden. Fehler beim Laden des Service: 500.
image of error on a map
Ein ähnliches Verhalten tritt bei dem Versuch auf, einen Szenen-Layer zu laden, der aus ArcGIS Pro für ArcGIS Enterprise unter Windows Server 2016 freigegeben wurde. Dabei wird der folgende Fehler zurückgegeben:
Error: 
Szenenservice weist keinen Stammknoten auf

Ursache

Beim Erstellen von Szenenservices muss ArcGIS Server mit ArcGIS Data Store vom Typ "Kachel-Cache" kommunizieren. ArcGIS Data Store-Komponenten vom Typ "Kachel-Cache" verwenden CouchDB zum Erstellen des Szenen-Cache. Die CouchDB erfordert SSL 3.0 für die Herstellung von Clientverbindungen. Dieses Problem tritt auf, wenn die SSL 3.0-Anforderung unter Window Server 2016 deaktiviert wird und ArcGIS Server deshalb nicht mit ArcGIS Data Store kommunizieren kann.

Lösung oder Problemumgehung

Abhängig von den jeweiligen Kommunikationsanforderungen gibt es zwei Möglichkeiten, dieses Problem zu beheben.

Aktivieren von SSL 3.0

Um die Kommunikation zwischen ArcGIS Server und ArcGIS Data Store zu ermöglichen, aktivieren Sie SSL 3.0 mithilfe der Schritte im folgenden Artikel: Problem: Beim Veröffentlichen gehosteter Szenen-Layer in ArcGIS Pro wird auf der Registerkarte "Auftragsstatus" angezeigt, dass das Caching fehlgeschlagen ist. Es wird aber keine Fehlermeldung ausgegeben.

Verwenden der HTTP-Kommunikation

Konfigurieren Sie den Data Store vom Typ "Kachel-Cache" für die Verwendung der HTTP-Kommunikation mit dem Hosting-Service. Für diese Aktion ist keine Aktivierung von SSL 3.0 auf den Hosting-Servercomputern erforderlich. Verwenden Sie das Data Store-Befehlszeilendienstprogramm "changedbproperties.bat", bei dem der Parameter "EnableSSL" auf "None" festgelegt ist.

  1. Klicken Sie in Windows auf die Schaltfläche Start, und geben Sie cmd in das Feld Programme/Dateien durchsuchen ein, um ein Befehlszeilenfenster zu öffnen.
  2. Klicken Sie mit der rechten Maustaste auf "cmd.exe", und klicken Sie dann auf dem Server, auf dem ArcGIS Data Store installiert ist, auf Als Administrator ausführen.
  3. Navigieren Sie zu:
    C:\ProgramFiles\ArcGIS\DataStore\tools (cd C:\ProgramFiles\ArcGIS\DataStore\tools)
  4. Führen Sie das Dienstprogramm "changedbproperties.bat" mit dem Befehl aus:
    changedbproperties.bat --store tileCache --enablessl none 

Weitere Informationen finden Sie unter ArcGIS Data Store – Hinweise zu Dienstprogrammen.

Artikel-ID:000017949

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden