PROBLEM

Eine Abfrage eines Kartenservice schlägt mit einem Fehler im Serverprotokoll fehl

Last Published: April 25, 2020

Beschreibung

Eine Abfrage eines Kartenservice schlägt mit dem folgenden Fehler im Serverprotokoll fehl:

Error: 
Das Wartezeitlimit wurde überschritten.

Ursache

Das Problem wird dadurch verursacht, dass der Prozesskern des Computers und die Instanzen für eine Abfrage großer Kartenservices nicht ausreichen. Standardmäßig generiert ArcGIS Server mehr ArcSOC.exe-Prozesse im Betriebssystem, um Abfragen großer Kartenservices zu verarbeiten. Beim Veröffentlichen von 50 dynamischen Kartenservices können beispielsweise über 100 ArcSOC.exe-Prozesse auf dem Computer generiert und ausgeführt werden. Allerdings kann festgelegt werden, dass ArcGIS Server nur maximal zwei Instanzen pro Kartenservice generiert, sodass auf dem Server nur bis zu 100 verarbeitet werden können. Dieser Mangel an Instanzen führt zu dem Fehler und zum Fehlschlagen des Abfrageprozesses.

Lösung oder Problemumgehung

Allgemein gilt für den Parameter "Maximale Anzahl Instanzen" die Faustregel "n + 1", wobei "n" die Anzahl der Kerne auf dem Servercomputer ist. Wenn der Parameter "maximale Anzahl Instanzen" auf einen höheren als den vorgeschlagenen Wert festgelegt ist, können bei Benutzern Performance-Probleme auftreten, da ArcGIS Server zusätzliche Ressourcen belegt. Dies kann zu einem Service-Absturz führen. Es empfiehlt sich, für den Core-Prozessor des Computers ein Upgrade auf den gewünschten Funktionsumfang durchzuführen, damit eine höhere Anzahl von Instanzen unterstützt wird. Die maximale Anzahl von Instanzen kann mit einem Administrator- oder Publisher-Konto über ArcGIS Server Manager geändert werden.

Um die optimale Anzahl von Instanzen für eine Service-Konfiguration zu bestimmen, überwachen Sie den Server über einen längeren Zeitraum. Beobachten Sie z. B., wie die Anwendungen die Instanzen verwenden. Wenn bei der Verarbeitung der Anforderungen die Wartezeit überschritten wird oder die Wartezeiten der Clients zu lang sind, müssen Sie möglicherweise die Anzahl der verfügbaren Instanzen anpassen. Ein Server kann große Mengen von Anforderungen auch dann verarbeiten, wenn er gerade erst eingeschaltet wurde. Er kann über 90 Threads starten, von denen jeder mehrere Anforderungen gleichzeitig verarbeiten kann. Jeder in den Speicher geladene Thread verfügt über alle Informationen, u. a. zur ArcGIS-Server-Sicherheit sowie zu Einstellungen und Services. Die Anzahl der Threads und die Speicherauslastung werden erhöht, wenn das System unter Last ist, um sicherzustellen, dass das System auch bei höherer Auslastung mit hoher Performance arbeitet. Eine Anpassung der maximalen Anzahl von Instanzen und des Timeout muss gut bedacht werden, um sicherzustellen, dass sich diese nicht auf die Computer- und Arbeits-Performance auswirkt. Der Server ist bereits für eine optimale Performance konfiguriert. Nehmen Sie Änderungen nur vor, wenn diese unbedingt erforderlich sind.

Im Knowledge Base-Artikel Problem: Die Anzahl der ArcSOC-Instanzen verursacht Performance-Probleme bei ArcGIS Server finden Sie Anweisungen zum Ändern der maximalen Anzahl von Instanzen pro Computer.

 

Artikel-ID:000017615

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden