Deutsch

How To: Konvertieren von IFC-Daten mit der Erweiterung "Data Interoperability"

Zusammenfassung

IFC-Daten (Industry Foundation Class) sind Open-Source-Daten, die mit der Erweiterung "Data Interoperability" in Esri dargestellt oder in Esri Formate konvertiert werden können. Angesichts der Komplexität und des Umfangs der Daten ist es erforderlich, die Daten-Layer zu filtern und die Ausdehnung der Features in den Daten zu ermitteln. Das IFC-Datenformat wird häufig für detaillierte Gebäudezeichnungen verwendet. Daher ist die Datenfläche in der Regel klein; sie entspricht einem Gebäudegrundriss und keiner ganzen Stadt.

Eine IFC-Datei enthält Daten-Layer wie Innenwände, Außenwände, Fenster und Türen. Sie kann auch weitere bautechnische Details wie Sanitär- und Elektroinstallationen enthalten.

Vorgehensweise

IFC-Dateien können groß sein. Daher sollten einige Empfehlungen zur Verwaltung der Datasets beachtet werden. Gehen Sie wie folgt vor, wenn Sie aus einer neuen IFC-Datei aussagekräftige Daten extrahieren möchten.

  1. Erstellen Sie in einem separaten ArcCatalog-Fenster eine Interoperabilitätsverbindung zur IFC-Datei (öffnen Sie dazu ArcCatalog in Windows.)
  2. Wenn nach der Einstellung der Parameter keine Daten angezeigt werden, ändern Sie den Wert unter Use Deprecated Reader von Nein in Ja. Zum Lesen älterer IFC-Dateien ist der Deprecated Reader erforderlich.
  3. Schließen Sie ArcCatalog, nachdem Sie die Verbindung zu den Daten-Layern in der Datei hergestellt haben.
  4. Öffnen Sie in ArcMap eine neue leere Karte, und öffnen Sie die Seitenleiste Katalog.
  5. Aktualisieren Sie die Interoperabilitätsverbindung zur IFC-Datei in ArcCatalog. Dadurch werden einige Layer entfernt, für die die IFC-Datei keine Features enthält.
  6. Klicken Sie im ArcMap-Fenster auf Daten hinzufügen, navigieren Sie zur Interoperabilitätsverbindung, und fügen Sie die vorhandenen Feature-Classes zur Karte hinzu. Feature-Classes mit der Kennzeichnung Keine Geometrie sowie in der Liste aufgeführte Tabellen können Sie überspringen.
  7. Wenn Sie die verfügbaren Feature-Typen zu ArcMap hinzugefügt haben, rufen Sie unter Ansicht > Eigenschaften: Datenrahmen die Registerkarte Allgemein auf, und legen Sie unter Karteneinheiten und Anzeigeeinheiten die Einheit Meter fest.
  8. Beachten Sie in der linken unteren Ecke des ArcMap-Fensters den Namen des Layers, der gerade auf dem Bildschirm dargestellt wird, um die Layer anzuzeigen, die Daten enthalten. Klicken Sie mit der rechten Maustaste auf den Datenrahmennamen (Layers), und aktivieren Sie die Option Alle Layer ausblenden. Aktivieren Sie anschließend die Namen von einem oder zwei Layern, die im ArcMap-Fenster dargestellt werden.
  9. Beschränken Sie sich dabei, wie zuvor angemerkt, auf Layer, die Daten enthalten. Alle anderen Layer können Sie aus der Liste entfernen.
  10. Klicken Sie mit der rechten Maustaste auf einen Layer, und rufen Sie die Option Auswahl > Alle auswählen auf. Dieser Vorgang nimmt einige Zeit in Anspruch.
  11. Klicken Sie nach Beendigung des Auswahlprozesses im oberen Bereich des ArcMap-Fensters auf Auswahl > Auf selektierte Features zoomen, um den Bereich zu vergrößern, in dem die Daten dargestellt werden.
  12. Klicken Sie mit der rechten Maustaste auf einen der zuvor ausgewählten Layer, rufen Sie unter Eigenschaften die Registerkarte Quelle auf, und geben Sie eine sinnvolle Ausdehnung für die Daten an. Die Daten können in einem bekannten Koordinatensystem oder mit lokalen Koordinaten erstellt werden.
  13. Importieren Sie die Daten mit dem Werkzeug Data Interoperability Quick Import oder einem Spatial ETL-Werkzeug aus der IFC-Datei in eine File-Geodatabase. Wenn die Daten in einem bekannten Koordinatensystem dargestellt werden (dies lässt sich anhand ihrer Koordinatenausdehnung ermitteln), definieren Sie die Projektion im Rahmen des Importvorgangs. Weitere Informationen zu diesem Thema finden Sie im Knowledge Base-Artikel 000007880.

Beachten Sie, dass es sich hier um 3D-Daten handelt. Daher lassen sich die konvertierten Daten am besten in einer 3D-Szene in ArcScene oder ArcGIS Pro darstellen. Nach der Konvertierung in eine File-Geodatabase werden die Daten innerhalb weniger Sekunden in ArcScene oder ArcGIS Pro 3D dargestellt.

Referenzinformationen