PROBLEM

Benutzerdefinierte Schriftart-Styles in ArcGIS-Server-Services werden in ArcMap angezeigt, aber nicht in Portal for ArcGIS oder ArcGIS Online

Last Published: April 25, 2020

Beschreibung

Beim Veröffentlichen eines Service mit benutzerdefinierten Schriftarten werden die benutzerdefinierten Schriftarten in ArcMap richtig angezeigt, in einer Karte oder einem Feature-Service werden sie jedoch nicht angezeigt. Dieses Problem betrifft ArcGIS Server-Karten-Services, Feature-Services und gehostete Feature-Services in Portal for ArcGIS.

Die folgenden Bilder veranschaulichen, wie die benutzerdefinierte Schriftart in ArcMap und in Portal for ArcGIS dargestellt wird.

ArcMap

The custom symbol font displays correctly in ArcMap.

Gehosteter Feature-Service in Portal for ArcGIS

The custom symbol font incorrectly displays in Portal for ArcGIS.

Ursache

Dieses Problem wird durch die Verwendung einer nicht unterstützten Schriftart verursacht. ArcGIS Server unterstützt nur TrueType- und OpenType-Schriftarten. Damit Schriftarten in einem GIS-Service verwendet werden können, müssen sie sich auf dem Server befinden oder in die GIS-Ressource eingebettet sein. Die meisten Schriftarten können beispielsweise in ein Kartendokument eingebettet werden.

Weitere Informationen finden Sie im folgenden Dokument der Webhilfe: ArcGIS Server: Allgemeine Probleme und Lösungen.

Lösung oder Problemumgehung

Gehen Sie zum Beheben des Problems folgendermaßen vor, um die benutzerdefinierten Schriftarten einem ArcGIS Server-Computer hinzuzufügen.

  1. Navigieren Sie auf dem Computer, auf dem ArcGIS Server installiert ist, zu C:\Windows\Fonts, und fügen Sie die Dateien für die gewünschten benutzerdefinierten Schriftarten hinzu. Bei Bedarf kann die in ArcMap verwendete Schriftart mit dem im folgenden Knowledge Base-Artikel beschriebenen Verfahren ermittelt werden: How To: Identify all fonts used in an ArcMap map document.

    Image of Windows font folder
     
  2. Starten Sie den ArcGIS-Server-Service neu, und veröffentlichen Sie den gehosteten Service in Portal for ArcGIS oder ArcGIS Online erneut.
  3. Löschen Sie den Browser-Cache.
  4. Rufen Sie Portal for ArcGIS oder ArcGIS Online auf. Öffnen Sie die Webkarte mit dem Feature-Layer, um zu überprüfen, ob die Symbole richtig angezeigt werden.

Artikel-ID:000017153

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden