BUG

Beim Upgrade einiger Geräte auf Android OS 7.x kann es vorkommen, dass vorhandene Webkarten erst nach dem Zurücksetzen auf die Standardeinstellungen und erneuter Installation von Collector for ArcGIS geöffnet werden

Last Published: April 25, 2020

Beschreibung

Beim Upgrade von bestimmten Android-Geräten auf Version 7.x kann es vorkommen, dass sich vorhandene Webkarten in Collector for ArcGIS nicht mehr öffnen. Es kann zudem sein, dass der Ladevorgang von Webkarten (auch von kostenlosen Testkarten) zwar gestartet, aber nicht richtig abgeschlossen wird. Die Layer und Grundkarten werden nicht dargestellt.

Ursache

Dies ist ein bekanntes Problem. Beim Upgrade einiger Samsung-Geräte kann es vorkommen, dass Benutzer vorhandene Webkarten erst nach dem Zurücksetzen auf die Standardeinstellungen und erneuter Installation von Collector for ArcGIS öffnen können. Hier liegt kein Kompatibilitätsproblem mit dem Android-Betriebssystem vor, denn Version 7.x wird in vollem Umfang von Collector for ArcGIS unterstützt.

Nachfolgend finden Sie eine Liste der Geräte, bei denen das beschriebene Verhalten nach einem Upgrade auf Android 7.x aufgetreten ist:

  • Samsung Galaxy Tab A
  • Samsung Galaxy Tab S2
  • Samsung Galaxy Note 4
Hinweis:
Der Fehler kann auch auf anderen Android-Geräten auftreten.

Problemumgehung

Warnung: 
Bevor Sie den folgenden Workaround durchführen, sollten Sie alle Daten und wertvollen Informationen sichern, da diese beim Zurücksetzen auf die Standardeinstellungen vom Gerät gelöscht werden.
  1. Vergewissern Sie sich, dass alle Offline-Bearbeitungen aus Collector for ArcGIS synchronisiert wurden.
  2. Sichern Sie alle Offline-Karten.
    1. Verbinden Sie das Android-Gerät über ein USB-Kabel mit einem PC.
    2. Rufen Sie im Windows-Explorer unter dem Gerät den Ordner ArcGIS_Collector auf.
    3. Kopieren Sie den gesamten Ordner auf den Desktop des PCs. Dies ist der Sicherungsordner.
  3. Setzen Sie das Gerät gemäß den Anweisungen in der Gerätedokumentation auf die Standardeinstellungen zurück.
  4. Installieren Sie anschließend Collector for ArcGIS neu.
  5. Stellen Sie die vorhandenen Offline-Karten wieder her:
    1. Verbinden Sie das Android-Gerät über ein USB-Kabel mit einem PC.
    2. Rufen Sie das Gerät im Windows-Explorer auf.
    3. Kopieren Sie den Ordner ArcGIS_Collector (Schritt 2) zurück in den internen Gerätespeicher.
  6. Starten Sie Collector for ArcGIS.

Artikel-ID:000017074

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen