Deutsch

Problem: In Survey123 for ArcGIS schlägt das Übermitteln eines Survey mit einem HEIC-Bild als Anlage mit dem Fehlercode 400 fehl

Beschreibung

Für mit einem iOS 11-Gerät (iPhone X, iPhone 8 Plus und iPhone 7) aufgenommene Bilder kann das HEIF-Bildformat (High Efficiency Image Format) verwendet werden, das auch als HEIC bezeichnet wird. Wenn der Survey mit einem HEIC-Bild als Anlage für eine Frage mit angefügtem Bild gesendet wird, schlägt die Übermittlung mit dem folgenden Fehler fehl.

Error:
Dieser Survey konnte aufgrund des folgenden Fehlers nicht gesendet werden: Code 400

Screenshot fo the error.

Ursache

HEIC-Dateien werden von Survey123 for ArcGIS nicht unterstützt. Dies ist eine bekannte Einschränkung.

Lösung oder Problemumgehung

Ändern Sie vor dem Aufnehmen des Bildes mit dem iOS-Gerät die Kameraeinstellung, um die aufgenommenen Bilder in einem anderen Format, z. B. JPEG, zu speichern. Die Kameraeinstellung des Geräts kann mit einer der folgenden Methoden geändert werden.

  • Deaktivieren von Live Photo
    1. Starten Sie die Kamera-App des iOS-Geräts, und suchen Sie das Live Photo-Symbol. Screenshot of the Live Photo icon.
    2. Wenn das Symbol gelb (oder goldfarben) ist, tippen Sie auf das Symbol, um Live Photo zu deaktivieren
    Hinweis:
    Bei jedem Starten der App wird Live Photo erneut aktiviert. Damit Live Photo dauerhaft deaktiviert bleibt, wählen Sie Einstellungen > Kamera > Einstellungen beibehalten, und wenden Sie die Einstellung an, die für Live Photo nach dem Ausschalten des Geräts beibehalten werden soll.
  • Festlegen der Kamera-Aufnahmeeinstellungen auf "Maximale Kompatibilität"
    1. Wählen Sie Einstellungen > Kamera > Formate.
    2. Wählen Sie auf dem Bildschirm Formate die Option Maximale Kompatibilität aus.

      Screenshot of the Formats screen to select Most Compatible.

Referenzinformationen