ERROR

Nach dem Upgrade auf Portal for ArcGIS 10.5.1 kann keine Anmeldung bei der Portaladmin-API durchgeführt werden.

Last Published: April 25, 2020

Fehlermeldung

Wenn ein Upgrade von Portal for ArcGIS auf Version 10.5.1 durchgeführt wird, während die zuvor installierte Version über einen konfigurierten Forwardproxyserver verfügt, kann der Benutzer sich bei der Portal for ArcGIS-Startanwendung und Freigabe-API, jedoch nicht bei der Portaladmin-API anmelden.

Ursache

Die Portaladmin-API kann keine Authentifizierung über den angegebenen Forwardproxyserver durchführen. Beim Anmeldeversuch ist einer der folgenden Fehler im Webbrowser aufgetreten:

Error: 
"Ungültiges Token"
oder
Sie sind nicht autorisiert, auf diese Ressource zuzugreifen.

Außerdem zeigen die Portal-Protokolle Meldungen in etwa folgendermaßen an:

Error:
Für den Benutzer 'portaladmin'. java.lang.Exception konnte kein Token erstellt werden: Der Server gab den HTTP-Statuscode 404 zurück. Erforderliche URL: https://portaladmin.domain.com:7443/arcgis/sharing/generateToken

Lösung oder Problemumgehung

Fügen Sie nach Möglichkeit vor dem Upgrade auf Portal for ArcGIS 10.5.1 den Systemeigenschaften von Portal for ArcGIS den JSON-Parameter "nonProxyHosts" des Forwardproxy hinzu.

  1. Melden Sie sich mit einem Administratorkonto bei der Portaladmin-API an.
    • Beispiel: https://portal.domain.com:7443/arcgis/portaladmin
  2. Wählen Sie System > Properties > Update (https://portal.domain.com:7443/arcgis/portaladmin/system/properties/update) aus.
  3. Fügen Sie den Forwardproxy-Einstellungen "nonProxyHosts":"portal.domain.com" hinzu (ersetzen Sie "portal.domain.com" durch den vollständig qualifizierten Domänenamen (FQDN) des Computers, auf dem Portal for ArcGIS installiert ist).
    • Beispiel:
"httpProxyHost":"forwardproxy.domain.com","httpsProxyHost":"forwardproxy.domain.com","httpProxyPort":80,"httpsProxyPort":443","nonProxyHosts":"portal.domain.com"
  1. Wählen Sie Update Properties aus, um die Änderungen zu speichern.
  2. Melden Sie sich von Portal for ArcGIS ab. Die Anwendung wird neu gestartet.
  3. Sobald Portal for ArcGIS neu gestartet wurde, melden Sie sich wieder bei Portaladmin an, um zu überprüfen, ob die Einstellungen gespeichert wurden.
  4. Erstellen Sie eine Sicherung mit dem ArcGIS Enterprise-Sicherungsprogramm.
  5. Sobald die Sicherung abgeschlossen wurde, führen Sie ein Upgrade auf Portal for ArcGIS 10.5.1 durch.
Wenn das Upgrade bereits durchgeführt wurde, gibt es zwei Möglichkeiten zum Beheben dieses Fehlers:
  • Wenden Sie sich an den technischen Support von Esri, um Hilfe beim Wiederherstellen der früheren Version von Portal for ArcGIS zu erhalten, oder
  • Ändern Sie die Seiten "catalina.properties" und "portal-config.properties" wie folgt:
  1. Beenden Sie über die Dienstekonsole (services.msc) den Windows-Dienst Portal for ArcGIS:
    • Geben Sie im Dialogfeld Ausführen services.msc ein, und drücken Sie die Eingabetaste.
  2. Erstellen Sie eine Sicherungskopie der Datei catalina.properties. Beispiel:
  3. Öffnen Sie die Datei catalina.properties mit einem Texteditor.
  4. Kommentieren Sie die folgenden Einträge aus:
    • http.proxyHost =
    • https.proxyHost =
    • http.proxyPort =
    • https.proxyPort =
    • nonProxyHosts =
  5. Speichern Sie die Datei catalina.properties.
  6. Erstellen Sie eine Sicherungskopie der Datei portal-config.properties. Beispiel:
  7. Öffnen Sie in einem Texteditor die Datei portal-config.properties.
  8. Kommentieren Sie die folgenden Einträge aus:
    • http.proxyHost =
    • https.proxyHost =
    • http.proxyPort =
    • https.proxyPort =
    • nonProxyHosts =
  9. Speichern Sie die Datei portal-config.properties.
  10. Starten Sie in der Dienstekonsole (services.msc) den Windows-Dienst Portal for ArcGIS.
  11. Melden Sie sich bei der Portaladmin-API von Portal for ArcGIS an (https://portal.domain.com:7443/arcgis/portaladmin).
  12. Wählen Sie System > Properties > Update aus.
  13. Fügen Sie "nonProxyHosts":"portal.domain.com" hinzu. Ersetzen Sie "portal.domain.com" durch den Namen des Hosts, auf dem Portal for ArcGIS installiert ist. Beispiel:
  • "httpProxyHost":"forwardproxy.domain.com","httpsProxyHost":"forwardproxy.domain.com","httpProxyPort":80,"httpsProxyPort":443","nonProxyHosts":"portal.domain.com"
  1. Wählen Sie Update Properties aus.
  2. Erstellen Sie eine Sicherung mit dem ArcGIS Enterprise-Sicherungsprogramm.

Artikel-ID:000016419

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden