BUG

Beim Tippen auf die Schaltfläche "Analyse" in einer Webkarte wird das Fenster "Analyse durchführen" auf einem Touchscreen-Gerät nicht geöffnet

Last Published: April 25, 2020

Beschreibung

In Version 10.5 von Portal for ArcGIS erfolgt trotz bestehender Verbindung zum Portal auf einem Touchscreen-Gerät nach dem Betätigen der Schaltfläche Analyse im Hauptmenü oder im Kontextmenü eines Layers keine Reaktion.

Ursache

Dies ist ein bekanntes Problem. Beim Betätigen der Schaltfläche Analyse in einer Webkarte wird das Fenster Analyse durchführen auf einem Touchscreen-Gerät nicht geöffnet.

Problemumgehung

Geplant ist, dieses Problem in Version 10.5.1 von Portal for ArcGIS zu beheben.

Damit Benutzer mit Touchscreen-Geräten in Version 10.5 Analysen durchführen können, muss die Konfigurationsdatei bearbeitet werden. Diese Datei befindet sich auf dem Computer, auf dem Portal for ArcGIS installiert ist. Klicken Sie auf den folgenden Webhilfe-Link, um mehr über diese Datei zu erfahren: Bearbeiten der Konfigurationsdatei für Portal for ArcGIS.

In den Anweisungen wird beschrieben, wie die Konfigurationsdatei für Portal for ArcGIS bearbeitet wird.

Hinweis:
Erstellen Sie eine Sicherungskopie Ihrer Datei config.js, bevor Sie sie ändern.
  1. Melden Sie sich mit einem Administratorkonto bei dem Server an, auf dem Portal for ArcGIS installiert ist.
  2. Beenden Sie den Portal for ArcGIS-Service.
  3. Navigieren Sie mit dem Datei-Explorer zur Datei config.js. Die Konfigurationsdatei befindet sich unter:
    • \ customizations\\webapps\arcgis#home\js\arcgisonline\config.js
  4. Öffnen Sie die Datei "config.js" in einem Texteditor, z. B. Notepad oder Notepad++.
  5. Fügen Sie die folgenden Paketreferenzen zur Datei config.js hinzu.
    Hinweis:
    Sofern die Datei nicht bearbeitet worden ist, muss der folgende Text ab Zeile 559 eingefügt werden.
    
    {
       name: "dgrid1",
      location: "../../jsapi/dgrid1"
    },
    {
      name: "dstore",                                                    
       location: "../../jsapi/dstore"
    },
    • Nachdem der Text hinzugefügt wurde, sieht die Datei wie folgt aus (siehe hervorgehobener Abschnitt in der folgenden Abbildung):

      Updated Portal Config
  6. Speichern Sie die Datei.
  7. Starten Sie Portal for ArcGIS neu.
  8. Auf einem Touchscreen-Gerät sollten Sie jetzt den Webbrowser aktualisieren.

Artikel-ID:000015656

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Weitere Informationen zu diesem Thema erkunden