ERROR

Externer Freigabeprozess fehlgeschlagen

Last Published: April 25, 2020

Fehlermeldung

Bei dem Versuch, eine Shapefile über ArcGIS Pro in ArcGIS Online zu veröffentlichen, wird die folgende Fehlermeldung zurückgegeben:

Error: 
Externer Freigabeprozess fehlgeschlagen
Image of the error message

Ursache

Dieser Fehler tritt wegen der Installation von Python mit ArcGIS Pro auf. In Version 1.3 wird Python mit ArcGIS Pro installiert. Dadurch entfällt die Notwendigkeit einer sekundären Installation von Python for ArcGIS Pro für die Ausführung von eigenständigen Python-Skripten. In einigen Fällen können mehrere Versionen von Python mit unterschiedlichen Umgebungen, wie zum Beispiel 32-Bit oder 64-Bit, auf demselben Computer installiert werden. Die Umgebungsvariable PYTHONPATH überschreibt die Variable PATH, mit der zu verwendende Version von Python festgelegt wird. Weitere Informationen finden Sie unter FAQ: Warum schlagen Python-Skripte auf einem Computer fehl, auf dem ArcGIS for Server und Desktop installiert sind?.

Hinweis:
Vor ArcGIS Pro Version 1.3 kann Python als eigenständiges Programm installiert werden. 

Lösung oder Problemumgehung

Wählen Sie je nach Ursache eine der folgenden Optionen, um das Problem zu beheben:

Warnung: 
Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme. 

Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Alle Änderungen erfolgen daher auf eigenes Risiko.
  • Entfernen der Python PATH-Umgebungsvariablen

    Diese Problemumgehung kann durchgeführt werden, ohne dass ArcGIS Pro deinstalliert werden muss.

    1. Klicken Sie in Windows auf Start, klicken Sie dann mit der rechten Maustaste auf Computer und klicken Sie auf Eigenschaften > Erweiterte Systemeinstellungen > Umgebungsvariablen.
    2. Suchen Sie im Fenster "Umgebungsvariablen" nach PYTHON oder PYTHONPATH auf der Registerkarte "Systemvariablen".
    3. Löschen Sie die Variablen PYTHON und PYTHONPATH. Damit wird die Python PATH-Umgebungsvariable entfernt.
    Hinweis:
    Nach dem Entfernen beider Variablen könnte die Python-Funktionalität in ArcMap beeinträchtigt sein, nicht jedoch für ArcGIS Pro.
    
  • Starten von ArcGIS Pro mit einem Batch-Skript

    Falls die Systemvariablen wegen der Abhängigkeit von aktiven Anwendungen, wie zum Beispiel ArcGIS Pro, auf demselben Computer nicht entfernt werden können, dann starten Sie ArcGIS Pro mit einer Batch-Datei, indem Sie die folgende Syntax verwenden:

    SET PYTHONPATH="" START "" "C:\Programme\ArcGIS\Pro\bin\ArcGISPro.exe"
    
  • Direktes Veröffentlichen in ArcGIS Online
    1. Komprimieren Sie die Shapefile mit einer Dateikomprimierungssoftware, wie zum Beispiel WinZip.
    2. Melden Sie sich bei www.arcgis.com an.
    3. Navigieren Sie zu Eigene Inhalte.
    4. Klicken Sie auf Element hinzufügen > Von meinem Computer.
    5. Wählen Sie die komprimierte Shapefile aus und fügen Sie einen Namen und die erforderlichen Tags hinzu. Klicken Sie auf Element hinzufügen.
  • Deinstallieren und erneutes Installieren von ArcGIS Pro

    Wenn die obigen Problemumgehungen nicht funktionieren, dann führen Sie eine vollständige Deinstallation und Neuinstallation von ArcGIS Pro durch. Diese Problemumgehung ist eine Alternative, wenn durch Entfernen der Python PATH-Umgebungsvariable der Fehler nicht behoben wurde.

    1. Deinstallieren Sie ArcGIS Pro in der Windows-Systemsteuerung. Die Schritte dazu finden Sie unter ArcGIS-Hilfe: Deinstallieren von ArcGIS Pro.
      Hinweis:
      Wenn der Deinstallationsprozess fehlschlägt, dann beenden Sie im Task-Manager alle aktiven ArcGIS Pro-Prozesse, bevor Sie den Versuch zur Deinstallation wiederholen. 
      
    2. Löschen Sie nach der Deinstallation von ArcGIS Pro die verbliebenen ArcGIS Pro-Dateien, die sich in der Regel in den folgenden Verzeichnissen befinden:
      C:\Benutzer\\AppData\Local\ESRI\ArcGISPro 
      (und alle weiteren Pro-Ordner)
      C:\Benutzer\\AppData\Roaming\ESRI\ArcGISPro
      C:\Programme\ArcGIS\Pro
      C:\ProgramData\Microsoft\Windows\StartMenu\Programs\ArcGIS\ArcGIS Pro
      Hinweis:
      Einige der oben aufgeführten Ordner sind möglicherweise versteckt. Informationen zum Anzeigen versteckter Ordner finden Sie unter Windows-Hilfe: Anzeigen ausgeblendeter Dateien.
    3. Suchen und löschen Sie die folgenden Registrierungsschlüssel:
      HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online For Pro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
      Warnung:
      Esri unterstützt Änderungen an der Registry des Betriebssystems nicht.
      
    4. Starten Sie den Computer neu und installieren Sie ArcGIS Pro erneut.

Artikel-ID:000015162

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden