PROBLEM

Die Funktionalität Eigene Position funktioniert nicht

Last Published: April 25, 2020

Beschreibung

In vielen Anwendungen und Webkarten werden Positionsschaltflächen, wie zum Beispiel "Eigene Position", "Eigenen Standort suchen" usw. verwendet, mit deren Hilfe veranlasst wird, dass die Karte bzw. Anwendung Ihren Standort in eine Vergrößerung oder ein Widget in einer Anwendung übernimmt. In einigen Browsern können diese Schaltflächen zu unerwarteten Ergebnissen führen. Nach dem Betätigen der Schaltfläche könnte eine Fehlermeldung ausgelöst werden oder gar nichts geschehen.

Ursache

Die Kontrolle über die Verwendung Ihres Standorts ist eine Funktionalität, die mehr durch den Browser als durch die Webkarte oder Anwendung gesteuert wird. Bei der Entwicklung von Browsern wurden zunehmend strenge Sicherheitsvorkehrungen zum Schutz der Privatsphäre implementiert.

  • Chrome: Ab Version 50 müssen alle Standortanforderungen über eine HTTPS-Verbindung bzw. eine sichere Verbindung erfolgen.
  • Safari: Version 10.0 und höher lässt die Funktionalität zur Geolokalisierung ausschließlich über HTTPS zu.
  • Internet Explorer: Version 11 lässt die Geolokalisierung noch über HTTP zu.
  • Edge: Edge funktioniert mit Geolokalisierung ausschließlich über HTTPS.
  • Mozilla Firefox: Version 50.1.0 lässt die Geolokalisierung noch über HTTP zu.

Lösung oder Problemumgehung

Überprüfen Sie die URL der Seite, auf die im Browser zugegriffen wird. Wenn Sie mit HTTP beginnt, dann ändern Sie die URL in HTTPS.
Beachten Sie, dass auch bei gemischten Inhalten Probleme auftreten können. Auf eine Anwendung kann über HTTPS zugegriffen werden. Wenn aber zum Beispiel ein Logo als HTTP-URL hinzugefügt wurde oder unter dieser URL gehostet wird, ist es notwendig, das Logo mit einer HTTPS-URL umzuhosten. Andernfalls könnte der Browser das unsichere Bild abfangen und unterstellen, dass die Site nicht sicher ist, und die Geolokalisierungsdienste blocken. Oft können Entwicklerwerkzeuge in Browsern oder einem Debugging-Werkzeug, wie zum Beispiel Fiddler, für die Diagnose dieser Probleme verwendet werden.

Artikel-ID:000014875

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden