ERROR

Fehler 1325. "EsriPyFldr" ist kein gültiger kurzer Dateiname.

Last Published: January 25, 2022

Fehlermeldung

Der Versuch, eine andere ArcGIS Desktop-Version zu deinstallieren, zu aktualisieren oder zu installieren (nachdem eine vorherige Version deinstalliert wurde), schlägt fehl und die folgende Fehlermeldung wird ausgegeben:

Fehler: Fehler 1325. "EsriPyFldr" ist kein gültiger kurzer Dateiname.
Fehler 1325.

Ursache

Das Problem kann aufgrund von beschädigten ArcGIS-Installationsordnern in ArcGIS Desktop auftreten. Verbliebene Ordner wurden nicht gelöscht und verbleiben in der Registrierung, ohne eine Verbindung zu einem anderen Ordner zu haben. Dies führt zu einer unvollständigen Deinstallation. Daher führt die Neuinstallation einer anderen Version von ArcGIS Desktop zu diesem Fehler.

Lösung oder Problemumgehung

Führen Sie eine saubere Deinstallation von ArcGIS Desktop durch, bevor Sie die neue Version installieren.

Gehen Sie wie folgt vor, um eine saubere Deinstallation von ArcGIS Desktop sicherzustellen:

  1. Deinstallieren Sie ArcGIS Desktop. Weitere Informationen hierzu finden Sie unter ArcMap: Deinstallieren von ArcGIS Desktop.
  2. Öffnen Sie nach Abschluss der Deinstallation den Windows Explorer, navigieren Sie zu C:\Programme (x86). Anschließend müssen Sie den Ordner ArcGIS entfernen oder umbenennen.
  3. Benennen Sie alle ArcGIS- und Esri-Ordner an den folgenden Speicherorten um:
  • C:\Programme (x86)
  • C:\Programme (x86)\Common Files
  • C:\Programme
  • C:\Programme\Common Files
  • C:\Program Data
  • C:\Benutzer\<Benutzername>\AppData\Local
  • C:\Benutzer\<Benutzername>\AppData\Roaming
  1. Navigieren Sie zur Windows-Registrierung und klicken Sie auf Start > Ausführen. Geben Sie regedit im Dialogfeld Ausführen ein, und drücken Sie die Eingabetaste.
Warnung: Mit den folgenden Informationen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Seien Sie also bei den folgenden Schritten vorsichtig, da Sie sie auf eigene Gefahr ausführen.
  1. Navigieren Sie zu [HKEY_LOCAL_MACHINE\SOFTWARE] und löschen Sie den Ordner Esri.
  2. Navigieren Sie zu [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node] und löschen Sie den Ordner Esri.
  3. Starten Sie den Rechner neu und führen Sie die Installationssoftware aus.
Note: Der Ordner "AppData" ist ausgeblendet. Informationen zum Anzeigen ausgeblendeter Ordner finden Sie unter Microsoft Hilfe: Anzeigen versteckter Dateien.
Hinweis: Wenn das Problem nach einer Neuinstallation immer noch besteht, kann es durch das auf dem Computer installierte Windows-Betriebssystem verursacht werden. Lesen Sie in der Microsoft-Hilfe: Beheben von Problemen, die das Installieren oder Entfernen von Programmen verhindern, um das Problem zu beheben.

Artikel-ID:000013304

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden