ERROR

Exportoperation ist fehlgeschlagen. Name ist NULL

Last Published: November 26, 2020

Fehlermeldung

Beim Exportieren einer ArcGIS-Server-Site (AGSSITE-Datei) mithilfe des Vorgangs "Export Site" im ArcGIS-Server-Administratorverzeichnis wird in den ArcGIS-Server-Protokollen der folgende Fehler zurückgegeben:

Error: Exportoperation ist fehlgeschlagen. Name ist NULL
[O-Abbildung]

Ursache

Für diesen Fehler sind die folgenden Ursachen möglich.

  • Das Auftragsverzeichnis von ArcGIS Server enthält eine gesperrte Datei eines vorherigen Auftrags. Dies kann passieren, wenn ein Auftrag nicht vollständig ausgeführt und inaktiv wird, sodass der Auftrag nicht exportiert wird.
  • Ein verwaistes Auftragsverzeichnis: Eine der Ursachen inaktiver Aufträge ist, dass der zugehörige primäre Prozess nach dem Abschließen des Tasks manuell gelöscht wird, ohne den inaktiven Prozess zu beenden.
  • Dieser Fehler kann beim Ausführen des Backup-Dienstprogramms von ArcGIS Server auftreten. Die Ursache kann eine beschädigte Installation von ArcGIS Server sein.

Lösung oder Problemumgehung

Zum Beheben des Fehlers können die folgenden Lösungen verwendet werden.

  • Entfernen Sie die inaktiven Aufträge, und exportieren Sie die Site erneut.
    1. Melden Sie sich bei dem Computer an, auf dem die ArcGIS-Server-Aufträge gehostet sind, navigieren Sie zu "C:\arcgisserver\config-store\system\jobs", und entfernen Sie den inaktiven Auftrag.
    2. Melden Sie sich beim ArcGIS-Server-Administratorverzeichnis an, und navigieren Sie zu Home > exportSite.Beziehen Sie die Parameter für Export Site bei Bedarf ein, und klicken Sie auf Export.
  • Installieren Sie ArcGIS Server erneut. Detaillierte Anweisungen finden Sie unter ArcGIS Enterprise: Willkommen bei der Installationsanweisung für ArcGIS Server (Windows).

Artikel-ID:000012918

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden