Deutsch

How To: Suchen der Differenzen von Raster-Werten zwischen zwei Rastern in ArcMap

Zusammenfassung

Werkzeuge für die räumliche Analyse, z. B. die Werkzeuge "Raster berechnen" und "Minus", können aufschlussreiche Informationen zu Raster-Wert-Differenzen zwischen Raster-Bildern liefern, die sich geographisch überlappen. In ArcGIS Desktop befinden sich diese Werkzeuge in der Toolbox "Spatial Analyst". In Umgebungen ohne die Erweiterung ArcGIS Spatial Analyst kann alternativ die Funktion "Differenz" im Fenster "Bildanalyse" verwendet werden.

Vorgehensweise

Hinweis:
Die Werkzeuge "Raster berechnen" und "Minus" erfordern eine Spatial Analyst-Lizenz.
 

In den folgenden Anweisungen werden die Schritte zum Ermitteln der Raster-Wert-Differenzen zwischen zwei Rastern beschrieben. In Option A wird der Workflow bei Verwendung des Werkzeugs "Raster berechnen" aus dem Toolset "Map Algebra" und in Option B der Workflow bei Verwendung des Werkzeugs "Minus" aus dem Toolset "Mathematik" beschrieben. In Option C werden die Schritte zum Ermitteln der Raster-Wert-Differenzen mit dem Werkzeug "Differenz" im Fenster "Bildanalyse" beschrieben, für das keine Erweiterung erforderlich ist.

  • Option A: Verwenden von "Raster berechnen"
  1. Navigieren Sie in ArcMap zu ArcToolbox > Spatial Analyst Tools > Map Algebra > Raster berechnen.
  2. Doppelklicken Sie im Fenster Raster berechnen auf eines der zu analysierenden Raster, klicken Sie auf das Minuszeichen (-), und doppelklicken Sie auf das zweite Raster.
  3. Geben Sie den Namen und Speicherort des Ausgabe-Rasters an.
  4. Klicken Sie auf OK.
User-added image
 
  • Option B: Verwenden des Werkzeugs "Minus"
  1. Navigieren Sie in ArcMap zu ArcToolbox > Spatial Analyst Tools > Mathematik > Minus.
  2. Fügen Sie die zu analysierenden Raster per Drag & Drop in die Felder ein, oder geben Sie die Raster an, indem Sie auf das Ordnersymbol klicken, um die Raster für die Felder Eingabe-Raster oder konstanter Wert 1 und Eingabe-Raster oder konstanter Wert 2 auszuwählen.
  3. Geben Sie den Namen und Speicherort des Ausgabe-Rasters an.
  4. Klicken Sie auf OK.
Image of the Math tool
 
  • Option C: Verwenden der Funktion "Differenz"
  1. Klicken Sie in ArcMap zum Öffnen des Fensters "Bildanalyse" im Hauptmenü auf Fenster, und klicken Sie auf Bildanalyse.
  2. Klicken Sie im Fenster Bildanalyse auf die gewünschten beiden Layer.
  3. Klicken Sie auf die Schaltfläche Differenz Difference. Hierdurch wird ein temporärer Layer erstellt, in dem die Differenzen zwischen den Rastern angezeigt werden.
Image Analysis Window
  1. Um den Layer aus Schritt 3 zu speichern, klicken Sie mit der rechten Maustaste auf den Layer, und navigieren Sie zu Daten > Daten exportieren. Wählen Sie den Speicherort aus, weisen Sie dem Ausgabe-Raster-Dataset einen Namen zu, und klicken Sie auf Speichern.
Export raster
Hinweis:
Stellen Sie sicher, dass die Pixelgröße und Projektionen beider Raster identisch sind. Verwenden Sie ggf. die Werkzeuge Resampling und Raster projizieren aus der Toolbox "Data Management", um die Pixelgröße bzw. Projektion der Raster zu ändern. Um die Genauigkeit des Ausgabe-Rasters sicherzustellen, können  mit dem Werkzeug Ausschneiden die Ausdehnungen der Raster verglichen werden.

Referenzinformationen