Deutsch

How To: Anzeigen einer AutoCAD-Zeichnungsdatei in ArcMap

Zusammenfassung

Dieser Artikel enthält Anweisungen zum Hinzufügen von AutoCAD-Zeichnungsdateien zu ArcMap, zum Erkennen von Problemen, die verhindern können, dass die Daten gezeichnet werden, und Tipps zum Beheben dieser Probleme in AutoCAD.

Vorgehensweise

Die folgenden Schritte sind nützlich, wenn sie auf eine AutoCAD-Zeichnungsdatei in der nativen Anwendung angewendet werden, bevor die Datei zu ArcMap hinzugefügt wird.

Hinweis:
ArcGIS Desktop unterstützt Features, die in AutoCAD Civil 3D oder AutoCAD Land Desktop mit Objektdaten erstellt wurden, nicht. Wenn diese Dateien in AutoCAD geöffnet und wieder gespeichert werden, können einige der Objektdaten in Entitäten konvertiert werden, die in ArcMap dargestellt oder in eine Geodatabase konvertiert werden. Die Verwendung von Objektdaten in AutoDesk-Dateien, die in ArcGIS Desktop hinzugefügt werden, sollte möglichst vermieden werden.

  1. Erstellen Sie eine Kopie einer AutoCAD-Datei.

    a. Speichern Sie eine Kopie der AutoCAD-Zeichnungsdatei mit einem Namen, der keine Leerzeichen oder Bindestriche enthält. Wenn der Name Leerzeichen oder Bindestriche enthält, dann ersetzen Sie diese Zeichen durch Unterstriche.
    b. Navigieren Sie zu "Einfügen > Externe Referenzen" und heben Sie die Zuordnung aller externen Referenzen zur Datei auf. Speichern Sie die AutoCAD-Zeichnungsdatei erneut.
    c. Navigieren Sie zu "Format > Einheiten". Notieren Sie sich die Einheiten, die zum Erstellen der Datei verwendet wurden.
    d. Navigieren Sie zu Layer Manager. Dort müssen Sie bei allen Layern, die ausgeschaltet, fixiert oder gesperrt wurden, diese Operation rückgängig machen, das heißt Einschalten, Fixierung aufheben bzw. Entsperren. Dies ermöglicht, dass die Daten in ArcMap dargestellt werden können.
    e. Speichern Sie die AutoCAD-Zeichnungsdatei.
  2. Fügen Sie die AutoCAD-Zeichnungsdatei zu ArcMap hinzu, um Features zu verändern.

    a. Öffnen Sie eine leere Karte in ArcMap.
    [O-Image]

    b. Navigieren Sie zur Werkzeugleiste Werkzeuge und wählen Sie die Dropdown-Liste Daten hinzufügen aus.
    [O-Image]

    c. Navigieren Sie zu der Position, an der die neue Kopie der AutoCAD-Zeichnungsdatei gespeichert wurde, und doppelklicken Sie auf die DWG-Datei.
    [O-Image]

    d. Fügen Sie nacheinander die einzelnen Feature-Typen aus der Datei hinzu. Dies hilft beim Isolieren der Feature-Typen, die Probleme verursachen.
    [O-Image]
    Hinweis:
    Wenn Feature-Typen einzeln zu ArcMap hinzugefügt werden, kann auf die einzelnen Layer-Eigenschaften zugegriffen werden. Wenn der Gruppen-Layer hinzugefügt wird, ist kein Zugriff auf diese Informationen möglich.


    Warnung:
    Wenn mit den Daten, die in der ArcMap-Sitzung angezeigt werden, Probleme auftreten, muss die AutoCAD-Zeichnungsdatei verändert werden. Siehe dazu die Schritte 3-5.

  3. Entfernen Sie in ArcMap die problematischen Layer in den DWG-Dateien. Klicken Sie mit der rechten Maustaste auf einen bestimmten Layer und wählen Sie Entfernen aus.
    [O-Image] [O]

  4. Navigieren Sie in AutoCAD zu "Bearbeiten > Alle auswählen" und verwenden Sie den Befehl "Trennen", um die Blöcke zu zerlegen.

    Hinweis:
    Der Befehl Trennen kann dazu führen, dass unzugängliche Features verfügbar sind. Der Befehl Trennen sollte mindestens einmal ausgeführt werden. Allerdings muss dieser Befehl möglicherweise mehrmals ausgeführt werden, da Blöcke bis zu neun Ebenen tief eingebettet sein können.

  5. Speichern Sie die Zeichnungsdatei in AutoCAD und wiederholen Sie Schritt 2.

Referenzinformationen