Deutsch
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

How To: Exportieren einer Attributtabelle von ArcMap nach Microsoft Excel

Zusammenfassung

In den folgenden Anweisungen werden einige Methoden beschrieben, um eine Attributtabelle nach Microsoft Excel zu exportieren.

Hinweis: Vor Office 2007 war Microsoft Excel auf 65.536 Zeilen und 256 Spalten beschränkt. In Office 2007 wurde diese Beschränkung auf 1.048.576 Zeilen und 16.384 Spalten erweitert.

Vorgehensweise

Verwenden des Werkzeugs "Tabelle in Excel" in ArcMap

  1. Öffnen Sie das .mxd-Projekt in ArcMap.
  2. Öffnen Sie das Werkzeug Tabelle in Excel über ArcToolbox > Conversion Tools > Excel > Tabelle in Excel.
Der Bereich
  1. Geben Sie im Fenster Tabelle in Excel über die Dropdown-Liste die Eingabetabelle an, oder ziehen Sie die Feature-Class aus dem Bereich Layer in den Abschnitt Eingabetabelle.
  2. Geben Sie für Ausgabe-Excel-Datei den Verzeichnispfad und den Namen der Ausgabetabelle an.
Das Fenster
  1. Klicken Sie auf OK. Die Excel-Datei wird im angegebenen Ausgabeverzeichnis erstellt.

Kopieren aller Datensätze der Attributtabelle und Einfügen der Datensätze in die Excel-Datei

  1. Öffnen Sie das .mxd-Projekt in ArcMap.
  2. Öffnen Sie die Attributtabelle des Layers, indem Sie mit der rechten Maustaste auf die Feature-Class klicken und dann auf Attributtabelle öffnen klicken.
Durch Klicken mit der rechten Maustaste auf den Layer wird die Option
  1. Klicken Sie in der Attributtabelle auf das Symbol Tabellenoptionen und dann auf Alle auswählen.
Das Dropdown-Menü
  1. Klicken Sie mit der rechten Maustaste auf die Spalte ganz links in der Attributtabelle, und wählen Sie Auswahl kopieren aus.
Durch Klicken mit der rechten Maustaste auf die Spalte ganz links in der Attributtabelle wird
  1. Öffnen Sie Microsoft Excel.
  2. Klicken Sie mit der rechten Maustaste in Zelle A1 der Excel-Datei, und wählen Sie Einfügen aus.
Die Excel-Datei mit der Zelle A1, durch Klicken mit der rechten Maustaste in die Zelle wird die Option
  1. Speichern Sie die Datei.

Exportieren der Attributtabelle in eine CSV-Datei

  1. Öffnen Sie das .mxd-Projekt in ArcMap.
  2. Öffnen Sie die Attributtabelle des Layers, indem Sie mit der rechten Maustaste auf die Feature-Class klicken und dann auf Attributtabelle öffnen klicken.
  3. Klicken Sie auf das Symbol Tabellenoptionen und dann auf Exportieren.
Das Dropdown-Menü
  1. Klicken Sie im Fenster Daten exportieren unter Ausgabetabelle auf die Schaltfläche "Durchsuchen", und navigieren Sie zu einem Speicherort, um die exportierte Attributtabelle zu speichern.
Das Fenster
  1. Klicken Sie im Fenster Daten werden gespeichert für Speichern als auf die Dropdown-Liste, und wählen Sie Textdatei aus.
Das Fenster
  1. Geben Sie im Abschnitt Name den gewünschten Namen an, und ändern Sie für den Namen die Dateierweiterung von .txt in .csv.
  2. Klicken Sie auf Speichern.
  3. Navigieren Sie in Windows Explorer zum Speicherort, um die .csv-Datei in Microsoft Excel anzuzeigen.

Referenzinformationen

Zuletzt geändert: 7/22/2021

Artikel-ID: 000012471

Software: ArcGIS for Desktop Advanced 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Basic 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Standard 10.3, 10.2.2, 10.2.1, 10.2, 10.1