ERROR

Das Programm kann nicht gestartet werden da die Datei LayerUILib.dll auf Ihrem Computer fehlt. Versuchen Sie das Programm erneut zu installieren um dieses Problem zu beheben

Last Published: April 25, 2020

Fehlermeldung

Beim Starten von ArcMap 10.2.x wird möglicherweise folgende Fehlermeldung angezeigt:

"Das Programm kann nicht gestartet werden, da die Datei "LayerUILib.dll" auf Ihrem Computer fehlt. Versuchen Sie, das Programm erneut zu installieren, um dieses Problem zu beheben."
[O-Image]

Ursache

Dieses Problem tritt auf, wenn die Datei "LayerUILib.dll" aus einer früheren Installation fehlt oder beschädigt ist.

Lösung oder Problemumgehung

Zum Beheben dieses Problems gibt es die folgenden zwei Möglichkeiten.

Möglichkeit 1: Reparieren der ArcGIS-Software

1. Wechseln Sie zu "C:\Programme (x86)\ArcGIS\Desktop10.2.x\bin".
2. Wenn die Datei "LayerUILib.dll" vorhanden ist, benennen Sie sie in "LayerUILib.OLD" um.
3. Klicken Sie im Windows-Menü "Start" auf "Systemsteuerung" > "Programme" > "Programme und Funktionen".
4. Klicken Sie mit der rechten Maustaste auf "ArcGIS 10.2.x for Desktop", und klicken Sie dann auf "Deinstallieren/Ändern".
5. Wählen Sie im Dialogfeld "ArcGIS 10.2.x for Desktop-Setup" die Option "Reparieren" aus, und fahren Sie mit der Installation fort, bis sie abgeschlossen ist.
[O-Image]
6. Starten Sie ArcMap.

Wenn sich das Problem mit der oben beschriebenen Lösung nicht beheben lässt, deinstallieren Sie die ArcGIS-Software vollständig.

Möglichkeit 2: Deinstallieren und erneutes Installieren der ArcGIS-Software

Warnung:
Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme.
Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Alle Änderungen erfolgen daher auf eigenes Risiko.


1. Klicken Sie im Windows-Menü "Start" auf "Systemsteuerung" > "Programme" > "Programme und Funktionen".
2. Klicken Sie mit der rechten Maustaste auf "ArcGIS 10.2.x for Desktop", und klicken Sie dann auf "Deinstallieren/Ändern".
3. Wählen Sie im Dialogfeld "ArcGIS for Desktop-Setup" die Option "Entfernen" aus, und fahren Sie mit der Deinstallation fort, bis sie abgeschlossen ist.


[O-Image]
4. Löschen Sie die folgenden Ordner:


C:\Program Files (x86)\ArcGIS\Desktop10.2
C:\ProgramData\FLEXnet


5. Löschen Sie die folgenden Registrierungsschlüssel:

Code:
HKEY_LOCAL_MACHINE\SOFTWARE\ESRI
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI


6. Installieren Sie die ArcGIS-Software neu.

Artikel-ID:000012072

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Weitere Informationen zu diesem Thema erkunden