Deutsch

How To: Erstellen von Verbindungslinien zwischen einem Punkt und einer Linie

Zusammenfassung

In den folgenden Anweisungen wird beschrieben, wie "Verbindungslinien" zwischen einer Point-Feature-Class und einer Line-Feature-Class erstellt werden. Dies kann dann sinnvoll sein, wenn die Entfernung von der Linie zu einem Punkt benötigt wird oder eine Verbindung von einer Linie zum nächstgelegenen Punkt dargestellt werden muss.

Vorgehensweise

  1. Fügen Sie die Line- und Point-Feature-Class einem leeren Kartendokument hinzu.
  2. Exportieren Sie eine Kopie der ursprünglichen Point-Feature-Class.
    Hinweis:
    Die ursprüngliche Point-Feature-Class kann zur besseren Übersichtlichkeit aus der Karte entfernt werden.
    1. Klicken Sie im Inhaltsverzeichnis mit der rechten Maustaste auf das ursprüngliche Punkt-Feature, und wählen Sie Daten > Daten exportieren aus.
    2. Navigieren Sie zu einem geeigneten Ausgabeverzeichnis, und geben Sie ihm einen geeigneten Namen, z. B. "Append_Points", und klicken Sie auf Speichern.
    3. Klicken Sie auf OK, um die Daten zu exportieren.
    4. Klicken Sie auf Ja, um zu bestätigen, dass die exportierten Daten der Karte als Layer hinzugefügt werden sollen.
  3. Öffnen Sie die Attributtabelle für den Punkt-Layer, und fügen Sie ein neues Feld hinzu. Geben Sie ihm einen Namen wie etwa "ConnectionNum".
    • Das Feld kann ein einfaches Feld des Typs "Short Integer" mit allen Standardwerten sein.
  4. Klicken Sie mit der rechten Maustaste auf den Feldnamen "ConnectionNum", und öffnen Sie die Feldberechnung.
  5. Doppelklicken Sie auf den Wert ObjectID, und führen Sie die Berechnung aus, um dieses neue Feld mit der ObjectID zu füllen.
    • Diese dient als Wert, der zum Verbinden des ursprünglichen Punktes mit dem auf der Linie liegenden Punkt herangezogen wird, die in den nachfolgenden Schritten erstellt wurde.
  6. Öffnen Sie das Werkzeug "Near" über die Toolbox: Analysis Tools > Nachbarschaftsanalyse (Proximity) > Near.
    Hinweis:
    Das Werkzeug "Nah" ist nur bei der Lizenzstufe "Advanced" verfügbar.
    1. Eingabe-Features ist der Punkt-Layer.
    2. Near-Features ist der Linien-Layer.
    3. Legen Sie den Suchradius fest (optional).
    4. Aktivieren Sie das Kontrollkästchen Position.
    5. Aktivieren Sie das Kontrollkästchen Winkel.
    6. Klicken Sie auf OK, um das Werkzeug auszuführen.
      [O-Image]
      Dadurch wird die Point-Feature-Class-Tabelle mit fünf zusätzlichen Feldern gefüllt:
      • Near_FID
      • Near_Dist
      • Near_X
      • Near_Y
      • Near_Angle
  7. Öffnen Sie das Werkzeug "XY-Ereignis-Layer erstellen" über die Toolbox: Data Management Tools > Layer und Tabellensichten > XY-Ereignis-Layer erstellen.
    1. XY-Tabelle ist die Point-Feature-Class.
    2. X-Feld ist Near_X.
    3. Y-Feld ist Near_Y.
    4. Legen Sie das Z-Feld fest (optional).
    5. Legen Sie die Ausgabe Layer-Name oder Tabellensicht fest, z. B.: "Line_Points_Layer".
    6. Legen Sie einen Raumbezug fest (optional).
    7. Klicken Sie auf OK, um das Werkzeug auszuführen.
      [O-Image]
      • Dadurch wird ein neuer Layer im Inhaltsverzeichnis erstellt, der die vom Werkzeug "Nah" berechneten Punkte (die auf der Linie liegenden Punkte) anzeigt.
  8. Öffnen Sie das Werkzeug Feature-Class in Feature-Class über die Toolbox: Conversion Tools > In Geodatabase > Feature-Class in Feature-Class, um den XY-Ereignis-Layer "Line_Points_Layer" in eine Feature-Class zu exportieren.
    1. Eingabe-Feature: Line_Points_Layer (weiter oben in Schritt 7d erstellter Layer).
    2. Ausgabespeicherort: Der Speicherort, an dem die Ausgabe-Feature-Class erstellt werden soll.
    3. Ausgabe-Feature-Class: Der Name der Ausgabe-Feature-Class, z. B. "Line_Points".
    4. Legen Sie den Ausdruck fest (optional).
    5. Legen Sie eine Feldzuordnung fest (optional).
    6. Klicken Sie auf OK, um das Werkzeug auszuführen.
      [O-Image]
  9. Öffnen Sie das Werkzeug "Anhängen": Data Management Tools > Allgemein > Anhängen.
    1. Eingabe-Datasets ist Line_Points_Layer (weiter oben in Schritt 7 erstellte Feature-Class).
    2. Ziel-Dataset ist die Feature-Class "Append_Points" (weiter oben in Schritt 2 erstellte Feature-Class).
    3. Wenn als Schematyp NO_TEST ausgewählt ist (optional), muss das Schema (bzw. die Felddefinitionen) des Eingabe-Datasets nicht mit dem Schema dieses Ziel-Datasets übereinstimmen.
    4. Behalten Sie die Feldzuordnung als Standardeinstellung bei (optional). Hiermit wird gesteuert, wie die Attributinformationen aus den Eingabe-Dataset-Feldern in das Ziel-Dataset übertragen werden.
    5. Legen Sie den Subtype fest (optional).
    6. Klicken Sie auf OK, um das Werkzeug auszuführen.
      [O-Image]
      • Dadurch werden sowohl die ursprünglichen Punkte als auch die Punkte angehängt, die auf der Linie in einer Feature-Class liegen.
  10. Öffnen Sie das Werkzeug "Punkte in Linie": Data Management Tools > Features > Punkte in Linie.
    1. Eingabe-Features ist die Feature-Class "Append_Points" (aus Schritt 9 weiter oben).
    2. Legen Sie einen geeigneten Speicherort für die Ausgabe-Feature-Class fest, und geben Sie ihr einen entsprechenden Namen, z. B. "Connection_Lines".
    3. Linienfeldist das Feld "ConnectionNum".
    4. Legen Sie das Sortierfeld fest (optional).
    5. Klicken Sie auf OK, um das Werkzeug auszuführen.
      [O-Image]
      • Damit wird die Verbindungslinie zwischen den Point- und Line-Feature-Classes erstellt. Die zusätzlichen Layer, die bei diesen Schritten erstellt wurden, können aus der Karte entfernt werden.

Referenzinformationen