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Problem: Lizenzserverstatus: WIRD NICHT AUSGEFÜHRT für ArcGIS License Manager 10.x

Beschreibung

Lizenzserverstatus: WIRD NICHT AUSGEFÜHRT für ArcGIS License Manager 10.x

Ursache

Nachdem die Software ArcGIS License Manager 10.x installiert oder erfolgreich ausgeführt wurde, kann der Status WIRD NICHT AUSGEFÜHRT auftreten. Als Ursache kommen verschiedenste Probleme infrage, wie zum Beispiel Firewalls, Virenschutz- oder Spamschutz-Anwendungen, die Zuweisung oder Verfügbarkeit von Ports, Umgebungsvariablen, Überbleibsel aus vorherigen Installationen oder das Vorhandensein früherer license.dat-Dateien.

Lösung oder Problemumgehung

Zur Lösung könnten die folgenden Schritte beitragen.

Bevor Sie es mit den unten beschriebenen Lösungen versuchen, sollten Sie die Debugprotokolldatei auf Fehlermeldungen prüfen. Auf diese Datei kann über "License Server Administrator > Diagnose" oder direkt in \ArcGIS\License10.x\bin\lmgrd9.log zugegriffen werden.

  • Deaktivieren Sie die Firewall. Nutzen Sie unten den Abschnitt mit den Referenzinformationen für den Zugriff auf die Schritte zum Konfigurieren von ArcGIS License Manager für die Arbeit mit einer Firewall durch Bearbeiten der Datei Service.txt.
  • Deaktivieren Sie den Virenschutz.
  • Führen Sie den Befehl Netstat –a aus, um festzustellen, welche aktiven TCP-Verbindungen offen sind und auf einem vernetzten Host ausgeführt werden. Dieser Befehl listet die verwendeten Protokolle, die lokale Adresse mit Portnummer, die Zieladresse mit Portnummer und den Status der Verbindung auf. Mit diesem Befehl können Sie ermitteln, ob Lizenzmanager-Ports im Bereich 27000-27009 gerade durch andere Prozesse verwendet werden.

    Führen Sie den folgenden Befehl in einer Eingabeaufforderung aus. Der Operator -a operator steht für die Option "Alle".

    netstat -a

  • Überprüfen Sie, ob der Dämon LMGRD manuell auf der Befehlszeile ausgeführt werden kann.

    Navigieren Sie zum Verzeichnispfad des jeweiligen Betriebssystems und führen Sie den Befehl zum manuellen Starten des Lizenzmanager-Dienstes aus:

    C:\> cd 'C:\Programme\arcgis\license10.1\bin'
    C:\> cd 'C:\Programme (x86)\arcgis\license10.1\bin'

    Starten Sie manuell den Lizenzmanager-Dienst:

    C:\> lmgrd.exe -c service.txt

    Wenn der Start erfolgreich war, liegt die wahrscheinlichste Ursache für dieses Problem in der Windows-Registrierung oder in den Umgebungsvariablen. Wenn es um die Umgebungsvariablen geht, dann führen Sie den nächsten Schritt aus.

  • Überprüfen Sie, ob Umgebungsvariablen eingerichtet wurden:

    1) Klicken Sie auf "Start > Systemsteuerung > System".
    2) Klicken Sie im Fenster "System" auf "Erweiterte Systemeinstellungen".
    3) Wählen Sie im Dialogfeld "Systemeigenschaften" die Registerkarte "Erweitert" aus.
    4) Wählen Sie die Schaltfläche "Umgebungsvariablen" aus.
    5) Blättern Sie im Fenster "Umgebungsvariablen" durch die Systemvariablen und überprüfen Sie, ob Umgebungsvariablen für ArcGIS License Manager eingerichtet wurden, wie zum Beispiel 'ARCGIS', 'ESRI' und 'LM', oder etwas, das aussieht, als könnte es von Esri oder Flexera stammen.
    6) Wenn Sie eine unnötige Variable entfernen möchten, dann wählen Sie die Variable aus und klicken auf die Schaltfläche "Löschen".

  • Überprüfen Sie, ob Überbleibsel aus einer vorherigen License Manager-Installation vorhanden sind:

    Im Softwareinstallationsverzeichnis je nach Betriebssystem:

    C:\Programme\ ArcGIS
    C:\Programme (86)\ArcGIS
    C:\Programme\Common Files\ESRI
    C:\Programme (86)\Common Files\ESRI
    C:\Dokumente und Einstellungen\\Application Data\ESRI
    C:\Users\\AppData\Roaming\ESRI

    In der Windows-Registrierung je nach Betriebssystem:

    HKEY_LOCAL_MACHINE > Software > ESRI
    HKEY_LOCAL_MACHINE > Software > WOW6432Node > ESRI
    HKEY_LOCAL_MACHINE > Software > Microsoft > Windows > CurrentVersion > Uninstall --> Registrierungsschlüssel überprüfen
    HKEY_CURRENT_USER > Software > ESRI
    HKEY_CURRENT_USER > Software > WOW6432Node > ESRI
    HKEY_CLASSES_ROOT > Installer > Products --> Registrierungsschlüssel überprüfen

  • Führen Sie das Process Monitor-Tool aus:

    Laden Sie das ProcMon-Tool auf der Seite Windows Sysinternals herunter.

    1) Wählen Sie "Process Monitor herunterladen" aus.
    2) Wählen Sie Öffnen aus.
    3) Doppelklicken Sie auf "ProcMon.exe" und wählen Sie Ausführen aus.
    4) Akzeptieren Sie die Lizenzbedingungen.
    5) Wählen Sie im Menü Filter die Option Filter aus.
    6) Wählen Sie unter 'Einträge anzeigen, die mit diesen Bedingungen übereinstimmen' die Option 'Prozessname' aus, wählen Sie 'enthält' aus und geben Sie arcgis.exe ein. Wählen Sie im letzten Dropdown-Menü die Option "Einbeziehen" aus und klicken Sie auf die Schaltfläche "Hinzufügen".
    [O-Image] Process Monitor

    7) Klicken Sie auf "Übernehmen" und dann auf "OK".
    8) Installieren Sie ArcGIS License Manager 10.1.
    9) Wenn die Installation abgeschlossen ist und in License Server Administrator der Status 'WIRD NICHT AUSGEFÜHRT' angegeben wird, dann speichern Sie das Protokoll in ProcMon. Wählen Sie "Datei > Ereignisse erfassen (Ctrl+E)" aus, um das Tracing zu beenden.
    10) Wählen Sie in ProcMon auf dem Computer "Datei > Speichern (Ctrl+S)" aus, um die Verfolgung als Trace in einer PML-Datei zu speichern.
    Speichern der Projektdatei

    [O-Image]
  • Löschen Sie den vertrauenswürdigen Speicher.

    Hinweis:
    Heben Sie zuerst die Autorisierung der Software auf, wenn diese Option verfügbar ist.

    Führen Sie die folgenden Schritte aus, um den vertrauenswürdigen Speicher zu löschen:

    1) Beenden Sie den Lizenzmanager-Dienst.
    2) Navigieren Sie zum FLEXnet-Ordner im Pfad des jeweiligen Betriebssystems:

    Windows XP und 2003 Server
    C:\Documents and Settings\All Users\Application Data\FLEXnet

    Windows Vista, 7 und Server 2008
    C:\ProgramData\FlexNet

    Unix/Linux:
    /usr/local/share/macrovision/storage

    3) Löschen Sie die Datei 'ArcGIS_xxxxxxxx_tsf.data' oder löschen Sie alle ArcGIS-Dateien im FlexNet-Ordner.
    4) Starten Sie die Lizenzmanager-Dienste.

Referenzinformationen