PROBLEM

ArcGlobe reagiert bei ArcID-Modul wird erstellt nicht mehr und wird nicht geöffnet

Last Published: December 1, 2020

Beschreibung

Nach der Installation von ArcGIS Desktop, reagiert ArcGlobe in einigen Fällen nicht mehr, wenn die Meldung "ArcID-Modul wird erstellt" angezeigt wird. Im Task-Manager ist zu erkennen, dass "ArcGlobe.exe" ausgeführt wird und Prozessorzeit beansprucht, aber die Anwendung wird nicht geöffnet.

Hinweis: Dieser Artikel gilt nur für die ArcGIS Server-Versionen 10.0 und früher. Höhere Versionen von ArcGIS enthalten möglicherweise andere Funktionalität sowie andere Namen für Menüs, Befehle und Geoverarbeitungswerkzeuge, die sich auch an anderen Orten befinden können.

Ursache

Auf Computern mit mehreren Prozessorkernen arbeiten einer oder mehrere Kerne möglicherweise mit maximaler Kapazität, während dies bei dem oder den anderen nicht der Fall ist. Wenn in einem solchen Fall die Auslastung des Prozessors nicht neu verteilt werden kann, wird ArcGlobe nicht vollständig geöffnet. Eine Beendigung des "ArcGlobe.exe"-Prozesses hat nicht zur Folge, dass die Prozessorauslastung automatisch ordnungsgemäß neu verteilt wird.

Warnung: Die folgenden Anweisungen betreffen die Änderung wichtiger Komponenten des Betriebssystems. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme. Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Seien Sie also bei den folgenden Schritten vorsichtig, da Sie sie auf eigene Gefahr ausführen.

Lösung oder Problemumgehung

Um dieses Problem zu umgehen, führen Sie die folgenden Schritte aus, um die Unterstützung mehrerer Prozessoren zu deaktivieren und anschließend erneut zu aktivieren.

Unter Windows 2000, Windows XP und Windows 2003:

  1. Editieren Sie die Datei "boot.ini" auf dem Computer, um die Unterstützung mehrerer Prozessoren zu deaktivieren.
  2. Klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und wählen Sie Eigenschaften aus.
  3. Klicken Sie im Fenster Eigenschaften auf die Registerkarte Erweitert.
  4. Klicken Sie im Bereich Starten und Wiederherstellen auf die Schaltfläche Einstellungen.
  5. Klicken Sie neben Klicken Sie auf "Bearbeiten", um die Startoptionen manuell zu bearbeiten auf Bearbeiten.
  6. Fügen Sie in der Datei "Boot.ini" nach der Option "/fastdetect" die Option "/numproc=1" hinzu. Klicken Sie auf Datei > Speichern. Schließen Sie die Datei "Boot.ini".
  7. Starten Sie den Computer neu. Öffnen Sie nach dem Neustart des Computers ArcGlobe. Die Anwendung sollte problemlos geöffnet werden.
  8. Nachdem ArcGlobe erfolgreich geöffnet wurde, schließen Sie die Anwendung. Führen Sie erneut die oben beschriebenen Schritte 1-3 aus, entfernen Sie die Option "/numproc=1" nach der Option "/fastdetect", und speichern Sie die Änderung.
  9. Führen Sie nochmals einen Neustart des Computers durch. ArcGlobe sollte nun ohne weitere Probleme geöffnet werden und ordnungsgemäß funktionieren.

In Windows Vista und Windows Server 2008 gibt es keine "boot.ini"-Datei. Stattdessen kann die beim Systemstart verfügbare Anzahl an Prozessoren in der Windows-Systemkonfiguration in den erweiterten Startoptionen definiert werden.

  1. Klicken Sie auf dem Windows-Desktop auf die Schaltfläche Start, und wählen Sie Ausführen aus.
  2. Geben Sie im Feld Ausführen den Befehl "MSCONFIG" ein, und drücken Sie die Eingabetaste.
  3. Die Windows-Systemkonfiguration wird geöffnet. Wählen Sie in der Systemkonfiguration die Registerkarte Start aus, und klicken Sie auf die Schaltfläche Erweiterte Optionen.
  4. Aktivieren Sie im Dialogfeld Erweiterte Startoptionen das Kontrollkästchen neben Prozessoranzahl, um das Dropdown-Menü für die Anzahl der Prozessoren verfügbar zu machen, und wählen Sie 1 als Anzahl verfügbarer Prozessoren aus.
  5. Starten Sie den Computer neu. ArcGlobe sollte nun ohne weitere Probleme geöffnet werden und ordnungsgemäß funktionieren.
  6. Nachdem ArcGlobe erfolgreich geöffnet wurde, schließen Sie die Anwendung. Führen Sie die Schritte 8-10 des vorherigen Abschnitts aus, aber ändern Sie die Anzahl verfügbarer Prozessoren zurück auf den ursprünglichen Wert.
  7. Führen Sie nochmals einen Neustart des Computers durch. ArcGlobe sollte nun ohne weitere Probleme geöffnet werden und ordnungsgemäß funktionieren.

Artikel-ID:000010286

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