PROBLEM

Die Installation reagiert nicht mehr, ohne dass Fehlerinformationen angezeigt werden

Last Published: November 20, 2020

Beschreibung

Beim Installieren bzw. Deinstallieren eines der folgenden Produkte der Version 9.2 oder der jeweiligen Service Packs reagiert die Installation nicht mehr: ArcGIS Server for the Microsoft .NET Framework, ArcIMS Web ADF for the Microsoft .NET Framework, Desktop SDK for the Microsoft .NET Framework, Engine SDK for the Microsoft .NET Framework und ArcGIS Explorer SDK.

Hinweis: Dieser Artikel bezieht sich auf die ArcGIS-Versionen 9.2, 9.3 und 9.3.1. Höhere Versionen von ArcGIS enthalten möglicherweise andere Funktionalität sowie andere Namen für Menüs, Befehle und Geoverarbeitungswerkzeuge, die sich auch an anderen Orten befinden können.

Wenn das Setup nicht mehr reagiert, wird in einigen Fällen die Meldung "Registering Visual Studio Express" in der Benutzeroberflächen für die Installation angezeigt. Ansonsten werden keine Informationen angezeigt.

Ursache

Mindestens eines von drei Microsoft Visual Studio Express Edition-Produkten ist auf dem Computer installiert, wenn die ArcGIS-Installation nicht mehr reagiert: Microsoft Visual Web Developer 2005 Express Edition, Microsoft Visual C# 2005 Express Edition oder Microsoft Visual Basic 2005 Express Edition.
Für alle Versionen der Visual Studio 2005 Express Edition muss die Registrierung innerhalb von dreißig Tagen nach der Installation erfolgen. Nach Ablauf von dreißig Tagen wird bei jedem Starten der Visual Studio Express Edition eine Aufforderung zur Registrierung angezeigt. Wenn ein Produkt, mit dem Vorlagen in Visual Studio Express integriert werden, zusätzlich zu einer Visual Studio Express Edition installiert wird, die nicht innerhalb des Zeitfensters von dreißig Tagen aktiviert wurde, reagiert die Installation nicht mehr. Ebenso reagieren Produkte, in die Visual Express-Vorlagen integriert sind, bei der Deinstallation nicht mehr, wenn Visual Studio Express nicht innerhalb von dreißig Tagen aktiviert wird. Dieses Problem wurde durch Microsoft dokumentiert.

Lösung oder Problemumgehung

  1. Falls die Installation bzw. Deinstallation nicht mehr reagiert, drücken Sie die Tasten STRG+ALT+ENTF. Klicken Sie auf die Schaltfläche Task-Manager, oder klicken Sie mit der rechten Maustaste auf die Windows-Schaltfläche "Start", und wählen Sie Task-Manager aus.
  2. Wählen Sie im Windows Task-Manager die Registerkarte Prozesse aus, und suchen Sie die folgenden Prozesse: VWDExpress.exe, VCSExpress.exe, VBExpress.exe sowie alle Prozesse mit dem Format msi*.tmp. Je nach installierter Visual Studio Express Edition werden möglicherweise nur einer oder aber mehrere dieser Prozesse aufgeführt.
  3. Klicken Sie mit der rechten Maustaste auf diesen Prozess, und wählen Sie Prozessstruktur beenden aus. Nach Beendigung dieser Prozesse sollte die Installation bzw. Deinstallation erfolgreich abgeschlossen werden.

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