PROBLEM

Auf dem Bildschirm werden keine ArcToolbox-Dialogfelder angezeigt

Last Published: April 25, 2020

Beschreibung

Die ArcToolbox-Dialogfelder werden auf dem Bildschirm nicht angezeigt. Auf der Taskleiste werden sie aber angezeigt.

Hinweis:
Die Informationen in diesem Artikel gelten für die ArcGIS-Versionen 8.x und 9.x. Höhere Versionen von ArcGIS enthalten möglicherweise andere Funktionalitäten sowie andere Namen für Menüs, Befehle und Geoverarbeitungswerkzeuge, die sich auch an anderen Orten befinden können.

Ursache

Als Fensterposition in der Registrierung wurden falsche oder negative Werte festgelegt.

Lösung oder Problemumgehung

Hinweis:
Bevor Sie eine der folgenden Prozeduren durchführen, sollten Sie einen zweiten Monitor anschließen und die Anzeigeeinstellungen in Windows erneut konfigurieren, indem Sie die Hauptanzeige erweitern. Wenn das Dialogfeld im erweiterten Anzeigebereich sichtbar ist, dann ziehen Sie es mit der Maus auf den primären Monitor. Schließen Sie ArcMap, und starten Sie das Programm erneut.

Wenn das Dialogfeld noch nicht sichtbar ist, dann versuchen Sie, die Bildschirmauflösung anzupassen. Wenn das Dialogfeld sichtbar ist, dann ziehen Sie es mit der Maus auf den primären Monitor. Schließen Sie ArcMap, und starten Sie das Programm erneut.

Ändern Sie die Fensterposition des Dialogfeldes in der Registrierung.

Warnung: 
Mit den folgenden Anweisungen werden Änderungen an entscheidenden Teilen Ihres Betriebssystems vorgenommen. Es wird empfohlen, eine Sicherung Ihres Betriebssystems und der Dateien, einschließlich der Registry, anzufertigen, bevor Sie fortfahren. Wenden Sie sich bei Bedarf an einen Fachmann für Computersysteme.

Für die Ergebnisse bei falschen Modifikationen, die mit diesen Anweisungen vorgenommen werden, kann Esri keine Garantie übernehmen. Alle Änderungen erfolgen daher auf eigenes Risiko.
  1. Navigieren Sie zu Start > Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
  2. Navigieren Sie zu HKEY_CURRENT_USER\Software\ESRI\ArcToolbox\Settings.
  3. Doppelklicken Sie auf DlgWindowPos, und legen Sie den Datenwert auf 1,1,1,1 fest.
  4. Klicken Sie auf OK.
  5. Schließen Sie den Registrierungs-Editor.
  6. Starten Sie ArcMap. Probieren Sie einige der ArcToolbox-Werkzeuge aus. Das Dialogfeld sollte jetzt auf dem Bildschirm angezeigt werden.
Hinweis:
In einigen Versionen von ArcGIS Desktop 10.x tritt das Problem auf, dass die neuen Registrierungseinstellungen nicht beibehalten werden. Dieses Problem wurde als BUG-000115257 protokolliert. 

Wenn dies der Fall ist, wird der folgende Workaround angeboten, allerdings sind einige Warnungen zu beachten.
Warnung:
Der folgende Workaround kann zu unbeabsichtigten Ergebnissen führen. Wenn die Vorlage "Normal.mxt" umbenannt wird, kann jede an ArcMap vorgenommene Anpassung verloren gehen, wie zum Beispiel aktivierte Werkzeugleisten, Positionen von Werkzeugleisten/Fenstern und Ordner-/Datenbankverbindungen.
  1. Navigieren Sie in einem Datei-Browser, wie zum Beispiel Windows Explorer, zum Ordner Templates. Der konkrete Pfad hängt von der verwendeten Version ab, muss aber dem folgenden allgemeinen Muster entsprechen:
    • C:\Benutzer\\AppData\Roaming\Esri\Desktop10.6\ArcMap\Templates
  2. Benennen Sie Normal.mxt um (zum Beispiel in Normal.mxt.old).
  3. Schließen Sie ArcMap, und öffnen Sie das Programm erneut.

Weitere Informationen zur Datei "Normal.mxt" finden Sie im folgenden Webhilfedokument: Grundlagen zum Speichern von Anpassungen.

Artikel-ID:000008829

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden