ERROR

1021: Token ist abgelaufen

Last Published: January 4, 2021

Fehlermeldung

Bei der Implementierung von WS-Security als Authentifizierungsmechanismus für den Zugriff auf ArcWeb Services kann die folgende Fehlermeldung auftreten:

Error: 1021: Token ist abgelaufen
Hinweis: Die Informationen in diesem Artikel gelten für das Retired-Produkt ArcWeb Services.

Ursache

Die Uhr des Client-Computers ist nicht mit der Uhr der ArcWeb-Server synchronisiert.

Lösung oder Problemumgehung

Synchronisieren Sie die Uhr des Client-Computers mit der Standardzeit, die von einigen NTP-Servern (Network Time Protocol) bereitgestellt wird. Die Zeitserver werden vom National Institute of Standards and Technology (NIST) verwaltet.

Bevor Sie beginnen

  1. Überprüfen Sie die Uhrzeit auf Ihrem Computer anhand des vom WWV-Sender der NIST ausgesendeten Signals. Eine Anleitung finden Sie im folgenden technischen Artikel: How To: Verify the time on the computer with National Institute Standards and Technology.
  2. Lesen Sie die Informationen unter NIST Internet Time Service (ITS).
  3. Wählen Sie den nächstgelegenen NIST ITS-Server zu Ihrem Standort aus: Tabelle der Internetzeitserver.
  4. Fahren Sie fort, indem Sie die unten stehenden Anweisungen zu Ihrer Domäne auswählen.

Computer mit Windows 2000 oder Windows XP in einem Enterprise-Netzwerk (Domäne)

  1. Fragen Sie den Systemadministrator, ob Ihr Computer zu einer Domäne gehört. Wenn ja, sind möglicherweise keine weiteren Maßnahmen erforderlich, da sich die Computeruhren automatisch auf die genaue Zeit einstellen können. Fahren Sie mit den folgenden Schritten fort, wenn Sie die Uhren für ein Netzwerk verwalten oder wenn Sie als Einzelperson auf ein Netzwerk zugreifen und eine sehr genaue Zeitanzeige auf Ihrem Computer benötigen.
  2. Öffnen Sie die Eingabeaufforderung durch Klicken auf Start > Alle Programme > Zubehör > Eingabeaufforderung.
  3. Geben Sie den folgenden Befehl ein:
    net time /setsntp:{Serveradresse}
    "Serveradresse" entspricht der Auswahl, die Sie in Schritt 3 oben getroffen haben. Beispiel: net time /setsntp:nist1-ny.glassey.com
  4. Starten Sie den Windows-Zeitdienst neu, um die Änderung in die Konfiguration zu übernehmen.
    1. Öffnen Sie Start > Alle Programme > Systemsteuerung > Verwaltung > Dienste. Wählen Sie den Dienst Windows-Zeit aus, und klicken Sie mit der rechten Maustaste darauf, um das Dialogfeld "Eigenschaften" zu öffnen.
    2. Klicken Sie auf Beenden und dann auf Starten, um den Dienst zu starten.
Hinweis: Mit dem folgenden Befehl kehren Sie zur ursprünglichen Konfiguration zurück: net time /setsntp Um herauszufinden, welchen externen NTP-Server der w32time-Dienst nach dem Neustart nutzt, verwenden Sie den folgenden Befehl: net time /querysntp

Computer mit Windows 2000 oder Windows XP, die sich nicht in einem Enterprise-Netzwerk befinden (Domäne)

  1. Doppelklicken Sie unten rechts auf dem Computerbildschirm auf die Uhrzeit, um die Systemsteuerungsoption Datum/Uhrzeit zu öffnen.
  2. Klicken Sie auf die Registerkarte Internetzeit.
  3. Aktivieren Sie das Kontrollkästchen Automatisch mit einem Internetzeitserver synchronisieren.
  4. Geben Sie in das Feld rechts neben Server den Namen des Servers ein, den Sie in Schritt 3 oben ausgewählt haben.
  5. Klicken Sie auf Jetzt aktualisieren, um die ordnungsgemäße Funktion sicherzustellen.
  6. Klicken Sie auf OK, um die Konfigurationsänderung zu bestätigen.

Faktoren, die sich auf die Genauigkeit des NTP-Protokolls auswirken

  • Entfernung zwischen Ihrem Computer und dem NTP-Server
  • Auslastung des Netzwerks
  • Firewall- oder Proxy-Server-Einstellungen

Probieren Sie verschiedene ITS-Server aus, falls einer dieser Punkte das Problem sein könnte.

Wenn die Firewall oder der Proxy-Server im Netzwerk als Ursache des Problems infrage kommt, prüfen Sie außerdem den UDP-Port 123. Der Windows-Zeitdienst verwendet den UDP-Port 123 für ein- und ausgehenden Verkehr. Es ist möglich, dass der Verkehr an Port 123 blockiert ist. Wenden Sie sich an einen Systemadministrator.

Artikel-ID:000008606

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