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Problem: Meldungen in der Lizenzmanager-Protokolldatei

Beschreibung

Dieses Dokument enthält verschiedene Meldungen, die in der Protokolldatei des Esri oder ArcGIS License Manager enthalten sein können.

Ursache

Fehler in Esri oder ArcGIS License Manager können verschiedenste Ursachen haben, die von fehlenden Berechtigungen bis zu einem falschen Hostnamen reichen.

Lösung oder Problemumgehung

Die Protokolldatei des Esri oder ArcGIS License Manager enthält den Status des Lizenzmanagers und ist beim Debugging von Problemen mit dem Lizenzmanager sehr nützlich. Standardmäßig wird sie im TEMP-Verzeichnis des Benutzers unter dem Namen "lmgrd.log" abgelegt. Sie können sie aber auch nach Bedarf umleiten und umbenennen.

  • Erstellen der Protokolldatei
    Den entsprechenden Link finden Sie unten im Abschnitt mit den Referenzinformationen.
  • Keine Protokolldatei
    Wenn der angegebene Lizenzmanager nach dem Neustart des Service nicht vorhanden ist, dann vergewissern Sie sich, dass Sie als Administrator beim Computer angemeldet sind.
  • Leere Protokolldatei
    Wenn die Protokolldatei des Lizenzmanagers vorhanden, aber leer ist, dann versuchen Sie, die Benutzerumgebungsvariable der Lizenzdatei festzulegen. Den entsprechenden Link finden Sie unten im Abschnitt mit den Referenzinformationen.
  • Treiber nicht installiert
<time> (ESRI) Logfile switched from stdout <time> (ESRI) The SuperPro Driver is not installed on this system <time> (ESRI) daemon shutdown requested - shutting down
Mögliche Ursachen für diese Fehlermeldung:
  1. Der Sentinel SuperPro-Hardwareschlüssel ist möglicherweise nicht ordnungsgemäß im Port eingesteckt.
    • Stellen Sie sicher, dass der Schlüssel in den parallelen oder den USB-Anschluss (je nach Typ des Schlüssels) eingesteckt ist.
    • Bei einem parallelen Schlüssel sollten Sie die Kontaktstifte im Hardwareschlüssel überprüfen, da verbogene Kontaktstifte einen Hardwareschlüssel funktionsunfähig machen können.
  2. Der Computer erkennt den Hardwareschlüssel nicht. Dies könnte daran liegen, dass der Treiber für den Sentinel Pro-Hardwareschlüssel nicht installiert ist. Wenn in "Status von Hardwareschlüsseln anzeigen" die folgende Fehlermeldung angezeigt wird: "Der SuperPro-Treiber ist auf diesem System nicht installiert, oder dieser Computer wurde noch nicht neu gestartet, seit er installiert wurde", dann überprüfen Sie Folgendes:
    1. Wenn die Installation von ARC/INFO durch einen Benutzer mit Administratorberechtigungen erfolgreich durchgeführt wurde, dann führen Sie einen Neustart durch, damit der Sentinel-Treiber aktiviert wird.
    2. Installieren Sie die aktuelle Version des Treibers für den Sentinel Pro-Hardwareschlüssel:
    3. Laden Sie den aktuellen Sentinel-Treiber von SafeNet herunter. Klicken Sie unter Sentinel Support auf Sentinel SuperPro. Klicken Sie unter Schritt 1 auf Download Driver, um die aktuelle Version herunterzuladen.
    4. Installieren Sie den Treiber. Wenn Sie die Option "Custom" auswählen, können Sie die Treiber für Hardwareschlüssel auswählen und installieren. Zusätzliche "Server"-Komponenten werden weder durch den Esri noch den ArcGIS License Manager verwendet und sind auch nicht erforderlich.
  • Hardwareschlüssel nicht installiert
Code: <time> (ESRI) The SuperPro hardware key is not installed on this system <time> (ESRI) daemon shut down requested - shutting down
Für USB-Schlüssel:
  1. Testen Sie den Port, um sicherzustellen, dass er ordnungsgemäß funktioniert. Stecken Sie zum Beispiel ein anderes USB-Gerät in den Port, und überprüfen Sie, ob es funktioniert.
  2. Wenn der Schlüssel weiterhin Probleme verursacht, dann laden Sie den aktuellen Treiber herunter, und installieren Sie ihn. Die Anweisungen dazu finden Sie im vorherigen Listenpunkt.
Für parallele Schlüssel:
  1. Überprüfen Sie den Hardwareschlüssel auf verbogene Kontaktstifte.
  2. Testen Sie den Port, um sicherzustellen, dass er ordnungsgemäß funktioniert. Schließen Sie zum Beispiel einen Drucker an, und drucken Sie über diesen Port.
  3. Dieser Fehler kann auch durch andere Geräte verursacht werden, die an den Hardwareschlüssel angeschlossen sind oder sich als Zusatz zu ihm im parallelen Port befinden. Trennen Sie vorübergehend die Verbindung dieser Geräte, um zu überprüfen, ob sie einander stören.
  4. Wenn ein Drucker an den Schlüssel angeschlossen ist, dann schalten Sie ihn ein. Manchmal gibt der Schlüssel nur bei eingeschaltetem Drucker einen Wert zurück.
  5. Wenn der Schlüssel weiterhin Probleme verursacht, dann laden Sie den aktuellen Treiber herunter, und installieren Sie ihn. Die Anweisungen dazu finden Sie im vorherigen Listenpunkt.
  • Falsche hostid
Code: <time> (ESRI) Wrong hostid, exiting (expected ESRI_SENTINEL_KEY=37101174, got ESRI_SENTINEL_KEY=37100548).
Diese Meldung erscheint, wenn die Nummer des eingesteckten Hardwareschlüssels und die Nummer von ESRI_SENTINEL_KEY in der Lizenzdatei nicht übereinstimmen.
Ersetzen Sie den eingesteckten Schlüssel durch den erwarteten Schlüssel. Wenn Sie keinen Hardwareschlüssel besitzen, dann fordern Sie eine neue Lizenzdatei an, die mit dem Hardwareschlüssel, den Sie besitzen, übereinstimmt, und aktualisieren Sie dann den Lizenzmanager-Dienst. Die Vorgehensweise zum Anfordern einer neuen Lizenzdatei und zum Aktualisieren des Lizenzmanager-Dienstes finden Sie über die Links im Abschnitt mit den Referenzinformationen.
  • Ungültiger Hostname
Code: <time> (lmgrd) "HOSTNAME" not a valid server hostname, exiting <time> (lmgrd) Valid server hosts are: "HOSTS" <time> (lmgrd) Using license file C:\Program Files\ESRI\License\*.lic
Wenn die Protokolldatei des Lizenzmanagers diese Fehlermeldung enthält und beim Starten des Esri oder ArcGIS License Manager-Dienstes in "Systemsteuerung" > "Dienste" die folgende Fehlermeldung angezeigt wird: "Der Dienst konnte nicht gestartet werden: Esri License Manager auf \\HOSTNAME Error 1067: Der Prozess wurde unerwartet beendet.", dann überprüfen Sie, ob der Hostname in der Zeile SERVER in der Lizenzdatei korrekt ist. Verwenden Sie den Befehl HOSTNAME an einer MS-DOS-Eingabeaufforderung, um den korrekten Hostnamen zu ermitteln.
Stellen Sie sicher, dass das Netzwerkprotokoll TCP/IP installiert ist. Dazu muss eine Netzwerkkarte oder der MS Loopback Adapter installiert sein. Bitten Sie Ihren Netzwerkadministrator um Unterstützung.
  • Vendor-Daemon abgestürzt
Code: <time> (ESRI) Vendor daemon can't talk to lmgrd (Cannot connect to license server (-15,11:10060) WinSock error code) <time> (lmgrd) Vendor daemon died with status 241 <time> (lmgrd) Since this is an unknown status, lmgrd will <time> (lmgrd) attempt to re-start the vendor daemon. <Zeit> (lmgrd) ESRI neu gestartet <internet tcp_port 0 pid <Nummer>
Diese Meldung wird mehrmals wiederholt.
Überprüfen Sie die folgenden Berechtigungen für das Verzeichnis "C:\flexlm", und legen Sie sie bei Bedarf fest. Die Gruppe SYSTEM muss Vollzugriff besitzen.
Ein weiterer Grund für diesen Fehler könnte sein, dass die IP-Adresse falsch ist und nicht aufgelöst werden kann. Wenden Sie sich an Ihren Netzwerkadministrator, um sicherzustellen, dass Ihre IP-Adresse aufgelöst werden kann.
  • Mehrere Sperrdateien
Code: <time> (ESRI) cannot open lock file (C:\flexlm\ESRI): Permission denied <time> (lmgrd) MULTIPLE "ESRI" servers running. <time> (lmgrd) Please kill, and run lmreread <time> (lmgrd) <time> (lmgrd) This error probably results from either: <time> (lmgrd) 1. Another copy of lmgrd running <time> (lmgrd) 2. A prior lmgrd was killed with "kill -9" <time> (lmgrd) (which would leave the vendor daemon running) <time> (lmgrd) To correct this, do a "ps -ax | grep ESRI" <time> (lmgrd) (or equivalent "ps" command) <time> (lmgrd) and kill the "ESRI" process
Beenden Sie den Lizenzmanager-Dienst. Navigieren Sie zu "C:\flexlm", und entfernen Sie alle vorhandenen Dateien. Starten Sie den Lizenzmanager-Dienst neu.

Referenzinformationen

Zuletzt geändert: 10/2/2020

Artikel-ID: 000005087

Software: Legacy Products