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Error: FLEXlm Error: -15 Die Verbindung mit dem Lizenzserver kann nicht hergestellt werden.

Fehlermeldung

Die folgende Fehlermeldung wird beim Starten einer ArcGIS Desktop-Anwendung angezeigt:

"FLEXlm Error: Cannot connect to license server. The server (lmgrd) has not been started yet, or the wrong port@host or license file is being used, or the port or hostname in the license file has been changed.
Feature: ARC/INFO
Server name: server1
License path: [Below are examples only]
@server1;c:\arcgis\arcexe82\sysgen\license.dat
@server1;c:\Prog~1\ESRI\License\arcgis9x
@server1;c:\Prog(x86)\ESRI\License\arcgis9x

FLEXlm error: -15,10. System Error: 10061 "WinSock: Connection refused"
For further information, refer to the FLEXlm End User Manual,
available at "www.globetrotter.com".
Program not run."

Ursache

ArcGIS kann keine Verbindung mit einem Lizenzserver herstellen, um eine Lizenz auszuchecken.

Lösung oder Problemumgehung

  1. Überprüfen Sie, ob der in der Fehlermeldung angegebene Lizenzpfad der richtige Hostname oder die richtige IP-Adresse des Lizenzmanager-Systems ist. Wenn der Lizenzpfad "Not_Set" ist, wurde im Desktop Administrator nicht der Lizenzmanager konfiguriert. Weitere Informationen finden Sie unter FAQ: Warum ist "Not_Set" im Desktop Administrator-Ordner für den Lizenzmanager aufgeführt?.
  2. Wenn der Lizenzpfad richtig ist, wird der Lizenzmanager möglicherweise nicht ausgeführt. Wenn auf das Lizenzmanager-System nicht zugegriffen werden kann, bitten Sie den Lizenzadministrator um Unterstützung. Führen Sie andernfalls die Schritte zur Problembehebung im Lizenzmanager-System aus.
  3. Starten Sie den Lizenzmanager neu:
    1. Klicken Sie auf Start > Programme > ArcInfo > Lizenzmanager > Lizenzmanager-Werkzeuge.
    2. Aktivieren Sie die Optionsschaltfläche Configuration using Services.
    3. Wählen Sie die Registerkarte Start/Stop/Reread aus.
    4. Klicken Sie auf Server beenden.
    5. Klicken Sie auf Server starten.
  4. Führen Sie eine Statusabfrage aus, um zu überprüfen, ob die Lizenzen verfügbar sind:
    1. Klicken Sie auf die Registerkarte Serverstatus und dann auf die Schaltfläche Statusabfrage ausführen . Alles anzeigen sollte ausgewählt sein.
    2. Überprüfen Sie, ob die Statusabfrage fehlerfrei ist. Weitere Informationen finden Sie unter Überprüfen des Lizenzserverstatus.
    3. Überprüfen Sie die Lizenzmanager-Protokolldatei auf Fehler.
    4. Klicken Sie auf der Registerkarte Konfigurationsservices auf Protokoll anzeigen. Weitere Informationen finden Sie unter Problem: Meldungen in der Lizenzmanager-Protokolldatei.
    5. Wenn die Statusabfrage und die Protokolldateien nicht auf Fehler hinweisen, wird möglicherweise eine Firewall im Lizenzmanager-System ausgeführt. Weitere Informationen finden Sie unter How To: Konfigurieren der Windows XP-Firewall für Internetverbindungen zur Verwendung mit Lizenzmanager.
    6. Wenn das Problem bestehen bleibt, bitten Sie den Esri Support um weitere Unterstützung.

Referenzinformationen