Deutsch

ArcGIS Runtime SDK for Qt 100.11 iOS App Store Patch

Zusammenfassung

Mit diesem Patch wird das Problem behoben, dass iOS-Apps mit ArcGIS Runtime SDK for Qt 100.11 im App Store abgelehnt werden. Esri empfiehlt allen Kunden, die ArcGIS Runtime for Qt SDK 100.11 verwenden, diesen Patch anzuwenden.

Beschreibung

Esri® kündigt den ArcGIS Runtime SDK for Qt 100.11 iOS App Store Patch an. Esri empfiehlt allen Kunden, die ArcGIS Runtime for Qt SDK 100.11 verwenden, diesen Patch anzuwenden. Dadurch werden die Probleme behoben, die unter Mit diesem Patch behobene Probleme beschrieben sind.

Mit diesem Patch behobene Probleme


  • BUG-000139861 - iOS apps rejected from App Store with Runtime SDK for Qt 100.11
  • Weitere Details:

    Wenn Sie mit Version 100.11 erstellte iOS-Apps an den iOS App Store senden, erhalten Sie diese scheinbar zusammenhanglose Ablehnungsmeldung:

     ITMS-90426: Invalid Swift Support - The SwiftSupport folder is missing. Rebuild your app using the current public (GM) version of Xcode and resubmit it.

    Durch den bereitgestellten Patch wird diese Ablehnung behoben, und Apps werden wieder vom App Store zugelassen.

    Nach Anwendung dieses Patch erhalten Sie möglicherweise eine neue Warnmeldung vom App Store, die App wird jedoch trotzdem akzeptiert. Dies wird in der nächsten Version behoben. Hier ein Beispiel für die Warnung:

    Dear Developer,

    We identified one or more issues with a recent delivery for your app, "App Name Here". Your delivery was successful, but you may wish to correct the following issues in your next delivery:

    ITMS-90863: Apple silicon Macs support issue - The app links with libraries that are not present on Mac:
    @rpath/libruntimecore.dylib

    Bei Bedarf können Sie diese Warnung umgehen, indem Sie Bitcode in Ihrem Projekt deaktivieren. Diese Warnung führt nicht zur Ablehnung durch den iOS App Store.


Installieren dieses Patch unter MacOS

Installationsschritte:

Das in der Tabelle aufgeführte ArcGIS-Produkt muss auf Ihrem System installiert sein, bevor Sie einen Patch installieren können. Jede Patch-Installation kann nur für das in der Liste aufgeführte ArcGIS-Produkt verwendet werden. Esri empfiehlt, für jedes auf Ihrem System installierte Produkt den entsprechenden Patch zu installieren.

  1. Laden Sie die Datei an einen anderen Speicherort als den ArcGIS Runtime SDK for Qt-Installationsspeicherort herunter.

  2.    
    Runtime SDK for Qt ArcGIS_Runtime_Qt_SDK_iOS_100_11_0_Patch.zip
    Checksum
         (SHA256)
    15E624372C15D47F2F3E546D8A87C6D51D5FEB00E1E6BE1B159A8B3A324819F2

  3. Doppelklicken Sie auf ArcGIS_Runtime_Qt_SDK_iOS_100_11_0_Patch.zip, um die ZIP-Datei zu extrahieren.

  4. Binden Sie im Projekt die neue Datei "qt_runtime_ios_framework.pri" nach den etwaigen bereits vorhandenen ArcGIS Runtime-Einbindungen in die PRO-Datei des Projekts ein.

  5. Beispiel:

     # Vorhandene Runtime-Einbindungen. Diese bleiben unverändert. ARCGIS_RUNTIME_VERSION = 100.11 include($$PWD/arcgisruntime.pri) # Fügen Sie diese zusätzliche Einbindung ein. Der Pfad variiert je nachdem, wohin Sie die Datei heruntergeladen haben. include(/Users/QtSdkUser/qt_ios_patch_100.11/qt_runtime_ios_framework.pri)

Aktuelle Informationen zu Patches

Prüfen Sie auf der Seite Patches und Service Packs regelmäßig, ob zusätzliche Patches zur Verfügung stehen. Neue Informationen zu diesem Patch werden hier veröffentlicht.

Support anfordern

US-Kunden wenden sich bitte an den technischen Support von Esri unter +1 888 377 4575, falls Probleme beim Installieren des Patch auftreten. Kunden außerhalb der USA wenden sich bitte an den jeweiligen Esri Softwaredistributor vor Ort.