Deutsch

ArcGIS Server 10.7 Print Service Secured Layer Patch

Zusammenfassung

Nach der Installation dieses Patch werden gesicherte Layer bei Verwendung des Druckservice korrekt exportiert.

Beschreibung

Esri® kündigt den ArcGIS Server 10.7 Print Service Secured Layer Patch an. Wenn Sie gesicherte Layer in Webkarten und einen Druckservice von ArcGIS Server 10.7 verwenden, kann gelegentlich das Problem auftreten, dass gesicherte Layer in der Druckausgabe fehlen. Nach der Installation dieses Patch werden gesicherte Layer bei Verwendung des Druckservice korrekt exportiert. Durch den Patch werden die Probleme behoben, die unter Mit diesem Patch behobene Probleme beschrieben sind.


Mit diesem Patch behobene Probleme


  • BUG-000120972 - Printing service fails when a secured service is used following a request when no token is used.

Installieren dieses Patch unter Windows


Installationsschritte:


Das in der Tabelle aufgeführte ArcGIS-Produkt muss auf Ihrem System installiert sein, bevor Sie einen Patch installieren können. Jede Patch-Installation kann nur für das in der Liste aufgeführte ArcGIS-Produkt verwendet werden. Um zu ermitteln, welche Produkte auf Ihrem System installiert sind, lesen Sie den Abschnitt Ermitteln der installierten ArcGIS-Produkte. Esri empfiehlt, für jedes auf Ihrem System installierte Produkt den entsprechenden Patch zu installieren.

  1. Laden Sie die entsprechende Datei an einen anderen Speicherort als den ArcGIS-Installationsspeicherort herunter.

  2. ArcGIS 10.7   Prüfsumme (Md5)
         
    ArcGIS Server ArcGIS-107-S-PSSL-Patch.msp CCC2F2EE1016E55C96CA89CBDBF5D72E
         

  3. Stellen Sie sicher, dass Sie Schreibzugriff auf das ArcGIS-Installationsverzeichnis besitzen.

  4. Doppelklicken Sie auf "ArcGIS-107-S-PSSL-Patch.msp", um das Setup zu starten.

    HINWEIS: Wird durch Doppelklicken auf die MSP-Datei die Setup-Installation nicht gestartet, können Sie die Setup-Installation mit dem folgenden Befehl manuell starten:

    msiexec.exe /p [Speicherort des Patch]\ArcGIS-107-S-PSSL-Patch.msp


Installieren dieses Patch unter Linux


Installationsschritte:


Führen Sie die folgenden Installationsschritte als Besitzer der ArcGIS-Installation aus. Der Besitzer der Installation ist der Besitzer des ArcGIS-Ordners.

Das in der Tabelle aufgeführte ArcGIS-Produkt muss auf Ihrem System installiert sein, bevor Sie einen Patch installieren können. Jede Patch-Installation kann nur für das in der Liste aufgeführte ArcGIS-Produkt verwendet werden. Um zu ermitteln, welche Produkte auf Ihrem System installiert sind, lesen Sie den Abschnitt Ermitteln der installierten ArcGIS-Produkte. Esri empfiehlt, für jedes auf Ihrem System installierte Produkt den entsprechenden Patch zu installieren.

  1. Laden Sie die entsprechende Datei an einen anderen Speicherort als den ArcGIS-Installationsspeicherort herunter.


    ArcGIS 10.7   Prüfsumme (Md5)
         
    ArcGIS Server ArcGIS-107-S-PSSL-Patch-linux.tar 3090006151B65566C56CC917AD1FE61F
         

  2. Stellen Sie sicher, dass Sie Schreibzugriff für das ArcGIS-Installationsverzeichnis haben und ArcGIS durch keinen anderen Benutzer verwendet wird.

  3. Extrahieren Sie die jeweilige TAR-Datei durch Eingabe des folgenden Befehls:

    % tar -xvf ArcGIS-107-S-PSSL-Patch-linux.tar

  4. Starten Sie die Installation durch die Eingabe des folgenden Befehls:

    % ./applypatch

    Es erscheint ein Dialogfeld für die menügesteuerte Installation. Die Standardauswahloptionen sind in Klammern ( ) angegeben. Die Installation kann jederzeit durch die Eingabe von "q" abgebrochen werden.

Deinstallieren dieses Patch unter Windows


    Um diesen Patch unter Windows zu deinstallieren, öffnen Sie die Windows-Systemsteuerung und navigieren Sie zu "Programme und Funktionen". Stellen Sie sicher, dass "Installierte Updates anzeigen" (links oben im Dialogfeld "Programme und Funktionen") aktiv ist. Wählen Sie den Patch-Namen in der Liste der Programme aus und klicken Sie auf "Deinstallieren", um den Patch zu entfernen.

Deinstallieren dieses Patch unter Linux


    Dieser Patch kann unter Linux nur bei Version 10.5.1 und höher deinstalliert werden.Um diesen Patch zu entfernen, navigieren Sie zum Verzeichnis "/.Setup/qfe" und führen das folgende Skript als Besitzer der ArcGIS-Installation aus:

    ./removepatch.sh

    Mit dem Skript removepatch.sh können Sie zuvor installierte Patches oder Hotfixes deinstallieren. Mit dem Status-Flag -s wird eine Liste der installierten Patches oder Hotfixes nach Datum sortiert aufgerufen. Mit dem Flag -q können Sie Patches oder Hotfixes in umgekehrter chronologischer Reihenfolge des Installationsdatums entfernen. Um Hilfe zu erhalten, geben Sie "removepatch -h" ein.

Aktuelle Informationen zu Patches

Prüfen Sie auf der Seite Patches und Service Packs regelmäßig, ob zusätzliche Patches zur Verfügung stehen. Neue Informationen zu diesem Patch werden hier veröffentlicht.

Ermitteln der installierten ArcGIS-Produkte

Um zu ermitteln, welche ArcGIS-Produkte auf dem Rechner installiert sind, wählen Sie die entsprechende Version des PatchFinder-Dienstprogramms für Ihre Umgebung, und führen Sie sie auf dem lokalen Computer aus. PatchFinder listet alle installierten Produkte, Hotfixes und Patches auf dem lokalen Computer auf.

Support anfordern

US-Kunden wenden sich bitte an den technischen Support von Esri unter +1 888 377 4575, falls Probleme beim Installieren des Patch auftreten. Kunden außerhalb der USA wenden sich bitte an den jeweiligen Esri Softwaredistributor vor Ort.