PROBLEM

CityEngine kann aufgrund eines OpenGL-Fehlers nicht über eine Remotedesktopverbindung gestartet werden

Last Published: April 25, 2020

Beschreibung

CityEngine wird nicht gestartet, wenn der Zugriff über eine Remotedesktopverbindung erfolgt.

Ursache

Dieser Fehler tritt auf, weil CityEngine für die Darstellung von Grafiken OpenGL 2.x erfordert. RDP (Remote Desktop Protocol) bietet keine OpenGL-Unterstützung für Client-Computer mit Versionen höher als 1.1. Daher wird beim Starten von CityEngine über eine Remotedesktopverbindung das Display mit OpenGL 1.x emuliert, was die Anzeige des folgenden Fehlers zur Folge hat.

OpenGL-Version Für CityEngine ist mindestens OpenGL 2.0 erforderlich. Ihre aktuelle Version (OpenGL 1.1.0, Microsoft Corporation GDI Generic) wird nicht unterstützt. Aktualisieren Sie Ihre Treiber oder wenden Sie sich an den Support.

[O-Abbildung] OpenGl-Fehlermeldung

Dieser Fehler tritt auch dann auf, wenn der physische Computer, auf dem CityEngine installiert ist, über eine zulässige OpenGL-Version verfügt.

Lösung oder Problemumgehung

Für dieses Problem gibt es zwei mögliche Lösungen.
  • Starten Sie CityEngine auf dem Computer, bevor Sie eine Remotedesktopverbindung initiieren.
oder
  • Erstellen Sie eine Batch-Datei, mit der die Verbindung der Remotedesktopsitzung getrennt und CityEngine automatisch auf dem Computer gestartet wird.

Beispiel für die Batch-Datei:

#Use query session in cmd to determine session ID, usually 1 #User running RDP must be an admin. #This disconnects RDP tscon 1 /dest:console #This starts CityEngine start "CE" "C:\Program Files\ESRI\CityEngine\CityEngine.exe"

Jetzt sind Verbindungen über RDP möglich, und CityEngine wird gestartet.

Artikel-ID: 000012119

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln