Fehlermeldung
Bei einer Bereitstellung auf mehreren Computern für ArcGIS Enterprise 11.x oder ältere Versionen funktioniert das Drucken von Karten nicht ordnungsgemäß und verursacht einen Fehler. Die Behebung dieses Problems gestaltet sich als sehr schwierig, da im ArcGIS Server Manager- oder Admin-Endpunkt der Status "Gestartet" angezeigt wird.
Häufig werden die folgenden Fehlermeldungen zurückgegeben.
Error executing tool. Export Web Map Task : Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service1_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service2_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service3_Name>/FeatureServer/0.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service4_Name>/FeatureServer/1.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service5_Name>/FeatureServer/0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
An unexpected error occurred while printing from Map Viewer on ArcGIS Enterprise Portal.
Einige Beispiele dafür, wie dies beim Drucken aus einer benutzerdefinierten Anwendung angezeigt wird, sind in den folgenden Screenshots dargestellt.


Ursache
Für dieses Problem sind eine Reihe von Ursachen möglich:
- Die Standard-URL für den PrintingTools-Service ist nicht konfiguriert unter: ArcGIS Enterprise Portal > Organization > Settings > Utilities Services > Printing
- Das SSL-Zertifikat ist nicht auf jeder Komponente von ArcGIS Enterprise korrekt konfiguriert.
- Fälle, in denen eine DMZ- oder MZ-Trennung (Demilitarized Zone, Demilitarisierte Zone bzw. Militarized Zone, Militarisierte Zone) von Computern in der Umgebung besteht, z. B. wenn ArcGIS Enterprise-Komponenten aufgrund von unterschiedlichen Sicherheitsstufen in zwei Zonen unterteilt sind.
- Ein Forwardproxy wird für den Internetzugriff auf ArcGIS Server-Computern verwendet, wenn sich der Computer in einer MZ befindet, in der kein Internetzugang für den Zugriff auf Online-URLs besteht.
- Die interne Kommunikation zwischen den Computern der ArcGIS Enterprise-Komponenten funktioniert nicht ordnungsgemäß. Die erforderliche Konnektivität und die Ports müssen überprüft werden.
Lösung oder Problemumgehung
Die unten aufgeführten Schritte haben in Hochverfügbarkeitskonfigurationen für ArcGIS Enterprise 11.x funktioniert.
- Konfigurieren der Standard-URL für den PrintingTools-Service unter: ArcGIS Enterprise-Portal, Registerkarte Organization > Settings > Utilities Services > Printing
https://machine.domain.in/arcgis/rest/services/Utilities/PrintingTools/GPServer
- "machine.domain.in" ist hier die öffentliche DNS-Adresse, die für den Zugriff auf ArcGIS Enterprise über das Internet konfiguriert wurde. Andernfalls handelt es sich um die URL für das ArcGIS Enterprise-Portal.
- Korrektes Konfigurieren des SSL-Zertifikats auf jeder Komponente von ArcGIS Enterprise:
- Konfigurieren Sie das entsprechende von der Zertifizierungsstelle (CA) oder der Domäne signierte SSL-Zertifikat auf jedem Computer:
- ArcGIS Server (Hosting): Alle beteiligten Computer
- ArcGIS Enterprise Portal: Sowohl Primär- als auch Standby-Computer
- ArcGIS Datastore: Sowohl Primär- als auch Standby-Computer
- Alle weiteren ArcGIS Server-Rollen/-Computer, die mit ArcGIS Enterprise verbunden sind.
- Wenn eine DMZ- oder MZ-Trennung von Computern in der Umgebung besteht und ein Forwardproxy für den Internetzugriff auf ArcGIS Server-Computern verwendet wird, konfigurieren Sie mithilfe der folgenden Schritte einen Forwardproxyserver für ArcGIS Server 11.x:
- Melden Sie sich mit dem primären Site-Administratorkonto unter der folgenden URL an:
https://machine.domain.com:6443/arcgis/admin
- Klicken Sie auf System > Properties > Update.
Befolgen Sie die unten beschriebenen Anweisungen zum Konfigurieren des Forwardproxy für Windows- und Linux-Computer: