Fehlermeldung
Wenn Sie den SAML-IDP für Active Directory Federation Services (AD FS) verwenden und versuchen, sich mit SAML-Anmeldedaten beim ArcGIS Enterprise-Portal anzumelden, wird der folgende Fehler zurückgegeben:
Anmeldung mit IDP ist nicht möglich. 'NAME_ID' nicht gefunden in SAML-Antwort
Ursache
Das SAML-Attribut "NameID" fehlt im <Subject>-Element der Antwort auf die SAML-Assertion.
Lösung oder Problemumgehung
- Öffnen Sie die AD FS Verwaltungskonsole.
- Wählen Sie Vertrauensstellungen der vertrauenden Seite aus. Wählen Sie im Fenster Vertrauensstellungen der vertrauenden Seite den Service-Provider für Ihr Enterprise-Portal aus.
- Klicken Sie auf der Registerkarte Aktionen auf Anspruchsausstellungsrichtlinie bearbeiten (ADFS 4) oder Anspruchsausstellungsrichtlinie bearbeiten (ADFS 3), wählen Sie die Ausstellungstransformationsregel aus, und klicken Sie auf Regel bearbeiten.
- Klicken Sie im Fenster Regel bearbeiten auf Regelsprache anzeigen.
- Überprüfen Sie, ob das Attribut Namens-ID mit dem folgenden Typ gesendet wird: http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier
- Wenn das Attribut fehlt, fügen Sie einen neuen Anspruch für das Attribut "Namens-ID" hinzu. Wählen Sie für Typ des ausgehenden Anspruchs in der Dropdown-Liste der Optionen den Wert Namens-ID aus.