ERROR

Fehler beim Laden von Web AppBuilder-Anwendungen oder verschiedene Grafikfehler im Internet Explorer nach der Installation der Windows-Aktualisierungen KB4487017, KB4487044, KB4486563, KB4486996

Last Published: April 25, 2020

Fehlermeldung

Es liegen bekannte Probleme mit einigen Windows-Aktualisierungen vom 12. Februar 2019 sowie Internet Explorer vor. Betroffen sind beispielsweise folgende Aktualisierungen:

Möglicherweise sind auch weitere Aktualisierungen betroffen.

Durch dieses Problem werden bei Web AppBuilder-Anwendungen im Internet Explorer Lade- und Grafikfehler verursacht. Fehler scheinen hauptsächlich bei Apps mit angepassten Widget-Symbolen aufzutreten. Dies wurde in erster Linie bei Web AppBuilder for Developers beobachtet, aber auch einige Versionen von Portal for ArcGIS oder heruntergeladene Anwendungen können davon betroffen sein. Beim Testen wurden keine Probleme mit ArcGIS Online und Portal 10.6.1 festgestellt, jedoch liegen Einschränkungen bei Portal 10.4.1 vor, wo folgende Fehler zurückgegeben werden:
Fehler: Zugriff wurde verweigert.
Error: Assertion failed: no binaryen method succeeded.

Konfigurierte benutzerdefinierte Bilder werden möglicherweise ebenfalls nicht geladen, wobei z. B. folgender Design-Fehler zurückgegeben wird:
Fehler beim Erstellen des Widgets: themes/FoldableTheme/widgets/HeaderController/Widget

Ursache

Dies ist ein bekanntes Problem. In der Microsoft-Aktualisierung KB4487017 wird auf Folgendes hingewiesen: "Nach der Installation dieses Updates kann Internet Explorer möglicherweise keine Bilder laden, deren relativer Quellpfad einen umgekehrten Schrägstrich (\) enthält."

Lösung oder Problemumgehung

Mögliche Problembehebungen:

  • Installieren eines Patch zur Problembehebung gemäß den Anweisungen von Microsoft, sofern verfügbar (siehe obige Links)
  • Deinstallieren der Aktualisierung
  • Bearbeiten der Anwendungskonfiguration zum Ändern der umgekehrten Schrägstriche in Bildpfaden zu normalen Schrägstrichen

Artikel-ID: 000020226

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln