HOW TO

Verbindung mit dem Portal oder mit Workflow Manager Server kann nicht hergestellt werden. Überprüfen Sie die Verbindung.

Last Published: March 13, 2024

Beschreibung

Beim Starten der Workflow Manager-Web-App über das App-Startprogramm in Portal for ArcGIS wird möglicherweise die folgende Fehlermeldung angezeigt:

"Unable to connect to the Portal or Workflow Manager Server. Please check the connection."

Darüber hinaus kann der Netzwerkverkehr anzeigen, dass eine Anforderung an "https://server.domain.com/server/workflow/checkStatus" Folgendes zurückgibt:

"500 - Could not access any server machines. Please contact your system administrator."

Wenn Sie jedoch einen Browser verwenden, um über den Port (https://server.domain.com:13443/workflow/checkStatus) auf den Endpunkt "checkStatus" zuzugreifen, wird "success=true" zurückgegeben.

Ursache

Dieses Problem tritt auf, wenn Portal for ArcGIS keine Verbindung zum Workflow Manager Server auf dem ArcGIS Server-Computer mit der Workflow Manager-Serverrolle herstellen kann.

Lösung oder Problemumgehung

Zuerst müssen die Zertifikate überprüft werden, die von Portal for ArcGIS und ArcGIS Server sowie vom Webserver (Java Tomcat oder Microsoft IIS) verwendet werden.

  • Ist das Ablaufdatum gültig?
  • Sind alle vollqualifizierten Domänennamen (FQDNs) der Computer als SAN-Werte (Subject Alternative Name) aufgeführt?
  • Ist das Portal for ArcGIS-Zertifikat in ArcGIS Server importiert und umgekehrt? Sind außerdem die Stamm- und Zwischenzertifikate in jede Website importiert?

Verwenden Sie als Nächstes den Windows PowerShell-Befehl Test-NetConnection. Informationen zur Überprüfung der Konnektivität für die folgende Route finden Sie in der Microsoft-Dokumentation zum NetTCPIP-Modul:

  • Sie müssen die Konnektivität vom ArcGIS Web Adaptor-Computer aus überprüfen:
  • Führen Sie in der Windows PowerShell auf dem Web Adaptor-Computer folgenden Befehl aus:
Test-NetConnection -ComputerName <wmx-machine-FQDN> -Port 13443 -InformationLevel "Detailed" 

Wenn dieser Test fehlschlägt, passen Sie die Regeln der Netzwerk-Firewall so an, dass der Test erfolgreich abgeschlossen werden kann. Sie sollten dann die Workflow Manager-Web-App erfolgreich über das Portal for ArcGIS-App-Startprogramm starten können.

Artikel-ID: 000032075

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln