PROBLEM

Werkzeuge werden mit leeren Dialogfenstern geöffnet

Last Published: April 25, 2020

Beschreibung

Unter bestimmten Umständen werden Geoverarbeitungswerkzeuge und Werkzeugleisten mit leeren Dialogfenstern geöffnet. Die Schaltflächen ("OK", "Abbrechen", "Umgebungen" etc.) funktionieren weiterhin ordnungsgemäß. Es wird möglicherweise sogar eine Bildlaufleiste im Dialogfeld angezeigt, wo normalerweise die Eingabe- und Ausgabeparameter angegeben werden, jedoch sind die Felder und Einstellungen nicht sichtbar.

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Ursache

Der Registrierungsschlüssel mit der Referenz zu "vbscript.dll" und anderen DLL-Dateien, die für die ordnungsgemäße Funktion von Werkzeugen erforderlich sind, wird von der Antivirensoftware McAfee überschrieben. Bei der Deinstallation der Antivirensoftware McAfee werden die Registrierungsschlüssel nicht in das native Format zurückversetzt. Dieses Problem kann ebenfalls mit der Antivirensoftware Avast auftreten. Führen Sie die folgenden Schritte aus, um zu überprüfen, ob es sich hierbei um die Ursache handelt:

  1. Öffnen Sie das Menü Start.
  2. Geben Sie in das Suchfeld den Begriff regedit ein, und drücken Sie die Eingabetaste.
  3. Überprüfen Sie die nachfolgenden Registrierungsschlüssel auf Übereinstimmung.
 HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}
  • Überprüfen Sie im rechten Fenster, ob der Wert "(Default)" vom Typ REG_SZ vorhanden ist und ob dort für Daten der Wert "VB Script Language" angegeben ist.
HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32
  • Überprüfen Sie im rechten Fenster, ob der Wert "(Default)" vom Typ REG_SZ vorhanden ist und ob dort für Daten der Wert "C:\Windows\system32\vbscript.dll" angegeben ist.
HKEY_CLASSES_ROOT\CLSID\{EE09B103-97E0-11CF-978F-00A02463E06F}\InprocServer32
  • Überprüfen Sie im rechten Fenster, ob der Wert "(Default)" vom Typ REG_SZ vorhanden ist und ob dort für Daten der Wert "C:\Windows\system32\scrrun.dll" angegeben ist.
[O-Image] Registry Editor
  1. Ist dies bei einem der Schlüssel nicht der Fall, versuchen Sie es mit der unten beschriebenen Lösung.

Lösung oder Problemumgehung

Ist McAfee derzeit installiert und muss weiterhin verwendet werden, müssen Sie sich an McAfee wenden. Ist McAfee installiert, jedoch nicht auf dem Computer erforderlich, deinstallieren Sie das Programm, bevor Sie mit der nachfolgenden Lösung fortfahren. Nachdem die Antivirensoftware McAfee deinstalliert wurde, führen Sie zur Problembehebung die folgenden Schritte aus:

  1. Laden Sie das Werkzeug McAfee Consumer Product Removal (MCPR) herunter, und befolgen Sie die Anweisungen unter Deinstallieren von McAfee-Produkten auf einem Windows-PC.
  2. Navigieren Sie zu dem Verzeichnis, in dem die MCPR-Datei gespeichert wurde.
  3. Klicken Sie mit der rechten Maustaste auf MCPR.exe, und wählen Sie Als Administrator ausführen aus.
  4. Folgen Sie den Eingabeaufforderungen.
  5. Starten Sie den Computer neu, wenn die Meldung CleanUp Successful eingeht.

Artikel-ID: 000011764

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