ERROR

Das Feature konnte nicht erstellt werden. Die Geometrie ist ungültig. Die Projektionsmethode kann kein Datum transformieren.

Last Published: January 26, 2022

Fehlermeldung

Wenn der Benutzer beim Bearbeiten eines Shapefile versucht, ein Feature zu erstellen, wird die folgende Fehlermeldung angezeigt:

Error: Das Feature konnte nicht erstellt werden. Die Geometrie ist ungültig. Die Projektionsmethode kann kein Datum transformieren.
Error.JPG

Ursache

Dieses Problem könnte eine der folgenden Ursachen haben: Beschädigung der Daten, eine beschädigte MXD-Datei oder eine Beschädigung der Anwendung ArcMap.

Lösung oder Problemumgehung

  1. Verwenden der Werkzeuge Geometrie überprüfen und Geometrie reparieren
    1. Öffnen Sie das Werkzeug Geometrie überprüfen, das sich im Toolset ArcToolbox > Data Management Tools > Features befindet.
    2. Wählen Sie den Layer mit Konflikten als Eingabe-Features aus, und legen Sie den Speicherort für die Ausgabetabelle fest.
    3. Analysieren Sie die Protokolldatei, um Konflikte zu bestimmen.
      • Wenn keine Konflikte vorhanden sind, dann fahren Sie mit dem nächsten Workaround fort.
      • Wenn die Protokolle Konflikte melden, dann verwenden Sie das Werkzeug Geometrie reparieren. Dieses befindet sich in demselben Toolset.
  2. Verwenden des Dienstprogramms MXD Doctor
    1. Öffnen Sie den MXD Doctor über das Windows-Menü Start > ArcGIS > MXD Doctor.
    2. Navigieren Sie zu der MXD-Datei, die den Layer mit Konflikten enthält.
    3. Analysieren Sie im Fenster Diagnose die Kontrollkästchen zum Bestimmen der Probleme, und klicken Sie auf die Schaltfläche Generieren, um einen Bericht zu erstellen.
    4. Klicken Sie auf die Registerkarte Behandlung, wählen Sie einen Zielordner aus, und klicken Sie auf Dokument reparieren, um ein Duplikat der MXD-Datei zu erstellen.
    5. Öffnen Sie das Duplikat der MXD-Datei, und testen Sie sein Verhalten. Wenn das Problem weiterhin besteht, dann fahren Sie mit dem nächsten Workaround fort.
  3. Erneutes Laden des Layers
    1. Erstellen Sie eine neue leere Karte in ArcMap.
    2. Ziehen Sie den Layer aus dem Bereich "Inhalt" in die Karte.
    3. Bearbeiten Sie den Layer. Wenn danach das Problem weiterhin besteht, dann fahren Sie mit einer sauberen Deinstallation von ArcMap fort.

Artikel-ID:000026954

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln