PROBLEM

Beim Starten von ArcGIS GeoEvent Server auf Servern auf denen McAfee Enterprise-Virenschutzlösungen ausgeführt werden tritt ein Fehler auf

Last Published: November 13, 2020

Beschreibung

Es hat sich erwiesen, dass eine Komponente der McAfee Enterprise-Virenschutzlösungen, nämlich der On-Access-Scanner, verhindert, dass ArcGIS GeoEvent Server ordnungsgemäß installiert und gestartet werden kann. Mit diesem Virenschutzprozessor werden sollen alle verwendeten Dateien gescannt werden. Bei Verwendung von stark komprimierten Archivdateien wie JAR-Dateien von GeoEvent Server können dabei mehrere Timeout-Fehler auftreten.
Im Falle eines Timeout-Fehlers wird von der McAfee-Virenschutzsoftware möglicherweise der folgende Fehler angezeigt:

Error: Der Scan von DATEINAME hat zu lange gedauert und wird abgebrochen. Die verwendete Version des Scanmoduls ist xxxx, DAT-Version xxxx.

Ursache

McAfee hat dieses Verhalten im McAfee Knowledge Center im technischen Artikel KB55869 dokumentiert: Ursache für das Auftreten von Scan-Zeitüberschreitungen:
"Bei Dateien mit einer der Erweiterungen .chm, .cab oder .zip handelt es sich um Archivdateien, die meist stark komprimiert sind. Beim Scannen dieser Archive muss jede darin enthaltene Datei extrahiert werden. Je nach Datentyp und Komprimierungsgrad des Archivs kann hierfür eine große Menge an Speicherplatz erforderlich sein."
Wenn kein Timeout-Mechanismus verwendet wird, kann es abhängig von verschiedenen Faktoren wie Dateityp vorkommen, dass Scans mehrere Stunden dauern und dass auf Dateien erst nach Stunden wieder zugegriffen werden kann. Mit Timeout-Mechanismen sollen längere Zeitspannen, in denen kein Zugriff möglich ist, verhindert werden, indem Scans beendet werden, die die konfigurierte Zeitbegrenzung überschreiten.
Dieses Problem kann sich auf andere Virenschutzprodukte auswirken, mit denen vergleichbare Scans durchgeführt werden.

Lösung oder Problemumgehung

Damit GeoEvent Server installiert und gestartet werden kann, deaktivieren Sie den Timeout-Mechanismus oder legen Sie für alle erforderlichen Dateien von GeoEvent Server in den folgenden Standardinstallationspfaden Ausnahmen fest:

C:\Program Files\ArcGIS\Server C:\ProgramData\Esri\GeoEvent C:\Users\arcgis\AppData

McAfee beschreibt im McAfee Knowledge Center im technischen Artikel KB58727 Langwieriger Scan-Vorgang bei Java-Anwendungen alternative Möglichkeiten zur Umgehung dieses Verhaltens wie etwa Deaktivieren des Archiv-Scans, Hinzufügen der entsprechenden Dateien zu einer Liste mit zulässigen Dateien und Ausschließen aller ähnlichen Dateien vom Scannen.

Artikel-ID:000012517

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Weitere Informationen zu diesem Thema erkunden