ERROR

Transport wird gestoppt da der erforderliche Layer [DatastoreConnection][Layer-Name] [LayerID] [Feature-Server] nach Abschluss der Synchronisierung nicht erreicht werden kann

Last Published: April 20, 2021

Fehlermeldung

Der folgende Fehler wird von einem Ausgabe-Konnektor in GeoEvent Manager (https://server.domain.com:6143/geoevent/manager/index.html) zurückgegeben, wenn der Feature-Service serverseitig (von ArcGIS Server) gestoppt wird:

Error: Transport wird gestoppt, da der erforderliche Layer [DatastoreConnection][Layer-Name] [LayerID] [Feature-Server] nach Abschluss der Synchronisierung nicht erreicht werden kann.

In der Ausgabe von GeoEvent fehlt die URL, die erforderlich ist, um Anforderungen an den REST-Endpunkt eines Feature-Service zu senden. Die Ausgabe sollte den Status "Gestartet" beibehalten und nicht in den Status "Fehler" wechseln.

Mit dem Fehler-Status soll nur angezeigt werden, dass eine Anforderung an einen Service, der vorhanden sein sollte, fehlgeschlagen ist, da der HTTP-Rückgabecode angibt, dass der Service nicht vorhanden ist.

Dies ist das erwartete Verhalten. Es scheint eine Einschränkung jeder serviceorientierten Architektur (SOA) zu sein, wenn ein externer Service unerwartet offline geht.
Je nach dem Typ des eingehenden oder ausgehenden Konnektors ist es möglich, dass der vom Konnektor verwendete HTTP-Client bei einer Anforderung an einen externen Web-Service einen HTTP/500-Fehler "general server/service" empfängt. Bei einer Eingabe wird in diesem Fall die Anforderung oder der Empfang von Daten gestoppt. Ein Ausgabe-Konnektor sendet keine Anforderungen mehr an den externen Service, um Daten von verarbeiteten Ereignisdatensätzen weiterzugeben.

Das Wesentliche dabei ist, zu erkennen, dass ein in einem Enterprise-Portal oder auf einem ArcGIS-Server gehosteter Feature-Service nicht besonders behandelt oder verarbeitet wird, weil er sich innerhalb des Ökosystems von Esri befindet.GeoEvent Server behandelt jeden Web-Service, der abgefragt wird oder an den Anforderungen gesendet werden, als einen externen Web-Service.

Während des Zeitraums, in dem der ausgehende Konnektor getrennt bleibt und einen Fehler-Status aufweist, werden keine empfangenen Echtzeitdaten über den ausgehenden Konnektor verbreitet. Empfangene Ereignisdatensätze sind weiterhin nicht verfügbar, da sie zum ausgehenden Konnektor geroutet werden, der nicht mehr verbunden und in Betrieb ist.

Zum Beheben des Fehlers sind einige grundlegende Schritte der Problembehandlung sowie Best Practices erforderlich, um zu verhindern, dass Konnektoren in den Fehler-Status wechseln und um Datenverluste zu vermeiden.

Ursache

Der Ausgabe-Konnektor zum Aktualisieren eines Features geht in einen Fehler-Status über, wenn der REST-Endpunkt des Ausgabe-Feature-Service nicht verfügbar ist. Der Feature-Service könnte aus folgenden Gründen nicht verfügbar sein:

  • Eine geplante Ausfallzeit, wie z. B. ein Server-Patching
  • Sicherung und Wartung der referenzierten Datenquelle (Enterprise-Geodatabase)
  • Ungeplante Ausfallzeiten, z. B. durch einen beschädigten Service oder wenn die ArcGIS-Server-Site offline ist
  • Wenn der Ausgabe-Feature-Service aus irgendeinem Grund gestoppt wird (Der Fehler kann durch einfaches Stoppen des Feature-Service vom jeweiligen Server Manager/Admin repliziert werden.)
  • Der Feature-Service wird recycelt
  • Kommunikationsverlust zwischen dem GeoEvent-Server und dem ArcGIS-Server, auf dem der Feature-Service gehostet ist

Dies wäre bei einem Service zu erwarten, der plötzlich nicht mehr verfügbar ist, da der Service gestoppt wurde (oder der ArcGIS-Server offline genommen wurde), und würde einen HTTP/500-Fehler erzeugen, wenn ein ausgeführter GeoEvent-Konnektor (eingehend oder ausgehend) eine Anforderung an den nicht verfügbaren Service gesendet hat.

Wenn ein GeoEvent Server-Konnektor (eingehend oder ausgehend) eine Anforderung an einen Feature-Service senden würde, der gerade recycelt wird, würde ebenfalls eine HTTP/500-Serverantwort erwartet werden. Der Service ist nicht verfügbar.

Lösung oder Problemumgehung

Bestimmen Sie zur Behebung des Fehlers die Schwachstelle anhand der oben genannten möglichen Ursachen.

  • Ist der ArcGIS-Server generell funktionsfähig?
  • Überprüfen Sie, ob der REST-Endpunkt des Service verfügbar ist.
  • Bestätigen Sie über den Server Manager oder Admin den Status des Service: entweder Start oder Gestoppt.
  • Verfügt der Feature-Service über zugehörige ArcSOCs?
  • Überprüfen Sie die referenzierte Datenquelle.
  • Greifen Sie über den GeoEvent-Computer auf den REST-Endpunkt zu. Stellen Sie fest, ob er verfügbar ist.
  • Untersuchen Sie die ArcGIS-Server-Protokolle, um die Problembehandlung fortzusetzen.

Der Ausgabe-Konnektor kann folgendermaßen wiederhergestellt oder wieder online gebracht werden:

  • Starten Sie den jeweiligen Ausgabe-Konnektor über den GeoEvent Manager-Endpunkt.
  • Stoppen und Starten des Ausgabe-Konnektors
  • Führen Sie über GeoEvent Manager > Site > Data Stores eine erzwungene Synchronisierung der GeoEvent Datastore-Verbindung durch.Synchronisieren Sie die Verbindung, über die der Service veröffentlicht wird.
  • Auf die nächste Service-Suche warten
Hinweis: Normalerweise sollte das Warten auf die nächste Service-Suche vermieden werden.Sollte die Service-Suche ausgeführt werden, während ein Service vorübergehend nicht verfügbar ist, und GeoEvent nicht in der Lage sein, die Eingabe(n) und/oder Ausgabe(n) wiederherzustellen, müsste bis zur nächsten Service-Suche (mehrere Stunden später) gewartet werden, wenn der bzw. die Feature-Service(s) verfügbar sind. Es ist leicht, in diesem Fall ungeduldig zu werden und nach einigen Minuten eine neue Service-Suche anzufordern, wenn es 20, 30, 45 Minuten oder länger dauern kann, bis eine Service-Suche für mehrere hundert Karten-/Feature-Services abgeschlossen ist, die von einem Hosting-Server gehostet werden, dessen Infrastruktur möglicherweise mehrere ArcGIS Server-Instanzen hat.

Weitere Informationen zum Überwachen einer Service-Suche finden Sie im Geonet-Blog unter Monitoring a registered web server's service discovery.

Empfohlene Best Practices

  • Systemadministratoren, denen bewusst ist, dass Server neu gestartet werden und dass bestimmte Web-Services ggf. vorübergehend nicht verfügbar sind, tragen die Verantwortung dafür, dass die Echtzeitverarbeitung, die diese Web-Services nutzt, angehalten oder gestoppt werden. Andernfalls wird von ihnen erwartet, dass sie einzelne Konnektoren stoppen und erneut starten – oder im schlimmsten Fall den GeoEvent Server neu starten, um die Service-Konnektivität wiederherzustellen. Stoppen Sie die Eingabe- und Ausgabe-Konnektoren sowie den GeoEvent-Service während des Patching bzw. der Wartung.
  • Erhöhen Sie den Parameter "Discovery Rate" für die registrierte(n) Serververbindung(en) von der Standardeinstellung – die 60 Minuten beträgt – auf etwa 1440 Minuten. Es kann auch ein deutlich größerer Wert festgelegt werden.
  • Begrenzen Sie die Anzahl der Feature-Services, die jeweils auffindbar sind, wenn GeoEvent Server die Service-Suche ausführt.
  • Binden Sie eventuell auch den ArcGIS-Server, unter dem GeoEvent Server ausgeführt wird, nicht ein, und konfigurieren Sie diesen ArcGIS-Server mit einer eigenen verwalteten relationalen Geodatabase, sodass Feature-Services, deren Feature-Datensätze wirklich in Echtzeit abgefragt und/oder aktualisiert werden, nicht mit den gehosteten Feature-Layern des Enterprise-Portals zusammenkommen. Sofern die Systemarchitektur keinen Big Data Store vom Typ "spatiotemporal" enthält, ist es ggf. möglich, den ArcGIS-Server des GeoEvent Server nicht einzubinden und nicht einmal eine Verbindung mit dem gehosteten Server des Enterprise-Portals zu registrieren.

Wie kann ein Datenverlust verhindert werden, wenn die zugehörigen Services unerwartet nicht mehr verfügbar sind?

Je nachdem, wie die Konnektoren implementiert sind, ist dies eventuell nicht möglich.

  • Die Ausgabe von GeoEvent Server ist nicht aktiv oder auch nur passiv mit einem Feature-Service verbunden. Die Ausgabe kann nur eine Reihe diskontinuierlicher Anforderungen an den Feature-Service senden und – durch Fehler – ermitteln, dass der betreffende Feature-Service zum aktuellen Zeitpunkt nicht verfügbar ist.
  • Die Ausgabe kann den Versuch in einigen hundert Millisekunden wiederholen, aber wenn weiterhin jede Sekunde oder alle 100 Millisekunden auf unbestimmte Zeit wiederholte Aufrufe an einen nicht verfügbaren Service erfolgen, kann GeoEvent Server kaum noch andere Ereignisverarbeitungs-Tasks durchführen und mit anderen ein- und ausgehenden Web-Services arbeiten, die verfügbar sind. Die einzige Möglichkeit besteht darin, der Ausgabe zu erlauben, die Verarbeitung auszusetzen, bis sie gestoppt und neu gestartet wird.

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