PROBLEM

Surveys können nicht über ArcGIS Survey123 Connect aktualisiert und veröffentlicht werden

Last Published: April 27, 2022

Beschreibung

Wenn Sie ArcGIS Survey123 Connect zum Veröffentlichen eines Survey verwenden, wird in ArcGIS Online ein Ordner des Survey erstellt, der den Feature-Layer sowie ein Formularelement und eine Webkarte enthält. Das sorgt für Flexibilität beim Migrieren des ArcGIS Online-Inhalts. In einigen Fällen wird der Veröffentlichungsprozess zwar geladen, jedoch nicht abgeschlossen, wenn der Survey mit Survey123 Connect aktualisiert und erneut veröffentlicht wird (siehe folgende Abbildung):

Die Veröffentlichungsseite eines Survey in ArcGIS Survey123 Connect, deren Ladeprozess zwar gestartet, aber nicht abgeschlossen wird

Ursache

Dieses Problem tritt auf, wenn das Formularelement des Survey in einen anderen Ordner in ArcGIS Online verschoben wird. Dies führt dazu, dass die Element-ID des ArcGIS Online-Ordners, in dem sich das Formularelement befindet, nicht mit der ID in der lokalen ITEMINFO-Datei des Survey übereinstimmt.

Bei der ursprünglichen Veröffentlichung des Survey wird die ID des ArcGIS Online-Ordners, in dem das Formularelement gespeichert ist, lokal in einer ITEMINFO-Datei gespeichert. Bei jeder nachfolgenden Veröffentlichung des Survey muss die ID in der ITEMINFO-Datei mit der ID des ArcGIS Online-Ordners übereinstimmen, in dem das Formularelement gespeichert ist.

Das Formularelement im ArcGIS Online-Ordner mit der ID, die mit der ID in der lokal gespeicherten ITEMINFO-Datei übereinstimmen muss

Lösung oder Problemumgehung

Gehen Sie zur Behebung dieses Problems wie folgt vor, um die ITEMINFO-Datei des Survey zu bearbeiten und sicherzustellen, dass die Element-ID mit der ID des ArcGIS Online-Ordners übereinstimmt, in dem das Formularelement gespeichert ist.

  1. Navigieren Sie in ArcGIS Online auf Inhalt > Eigene Inhalte.
  2. Navigieren Sie zu dem Ordner, in dem das Formularelement gespeichert ist, und kopieren Sie die Element-ID des Ordners aus der Adressleiste des Webbrowsers, wie in der folgenden Abbildung dargestellt.
Die Seite des Survey-Ordners, auf der die Element-ID des Ordners in der Adressleiste angezeigt wird
  1. Navigieren Sie auf dem lokalen Computer zu dem Survey-Ordner, und öffnen Sie die ITEMINFO-Datei des Survey in einem Text-Editor.
Die ITEMINFO-Datei des Survey, die im Explorer-Verzeichnis des lokalen Computers angezeigt wird
  1. Suchen Sie den Parameter "ownerFolder", und vergewissern Sie sich, dass die Werte mit der Element-ID aus Schritt 2 übereinstimmen. Falls sich die Element-ID unterscheidet, aktualisieren Sie die Parameterwerte mit der in Schritt 2 kopierten Element-ID, und klicken Sie auf Save.
Ändern des Parameters
  1. Veröffentlichen Sie den Survey erneut über Survey123 Connect.

Artikel-ID: 000025001

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln