HOW TO

Benutzerdefinierte Symbole können nicht in der Symbolauswahl gespeichert werden

Last Published: October 1, 2025

Beschreibung

In den Dialogfeldern für die Symbolauswahl wird eine Palette von Symbolen angezeigt, die sich in einem der aktuell referenzierten Styles oder in den persönlichen Styles eines Benutzers befinden. Mit der Symbolauswahl können Benutzer benutzerdefinierte Symbole implementieren, wenn keines der gewünschten Symbole in der Palette vorhanden oder schwer zu finden ist.

Benutzer können jedoch keine benutzerdefinierten Symbole in der Symbolauswahl speichern, wenn die Schaltfläche "Speichern unter" im Dialogfeld "Symbolauswahl" deaktiviert ist.

[O-Abbildung]

Ursache

Die Schaltfläche kann aus folgenden Gründen deaktiviert sein:

  • Die STYLE-Datei ist schreibgeschützt.
  • Es gibt ein Problem im Zusammenhang mit der Datei "Normal.mxt".
  • Die Daten oder die MXD-Datei sind beschädigt.

Lösung oder Problemumgehung

Je nach Fehlerursache stehen verschiedene Workarounds zur Verfügung.

Note:
Close all Esri applications running on the system before proceeding to the workaround.

Stellen Sie sicher, dass Lese- und Schreibzugriff auf die STYLE-Datei vorhanden ist.

Diese Datei befindet sich unter:

C:\Users\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap
Note:
Enable 'Show Hidden Files and Folders' if unable to locate the application data folder. This can be done in Windows 7 or 8 by clicking Organize Drop-down > Folder and Search Options > View Tab > Show Hidden Files and Folders.
[O-Abbildung]

Umbenennen der Datei "Normal.mxt"

  1. Navigieren Sie zum folgenden Verzeichnispfad:
C:\User\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap\Templates
  1. Klicken Sie mit der rechten Maustaste auf die Datei "Normal.mxt", und klicken Sie auf Umbenennen.
  2. Benennen Sie die Datei in "Normal_old.mxt" um.
  3. Starten Sie ArcMap.
Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a back up of the operating system and files, including the registry, before proceeding. Consult a qualified computer systems professional if necessary.
Be aware that renaming the Esri folders is a factory reset of ArcGIS, and therefore all third party tools, custom scripts, or custom toolbars currently installed must be reinstalled accordingly. Additionally, all existing folder connections must be reconnected.
Esri cannot guarantee results from incorrect modifications while following these instructions. Proceed with caution.
Note:
If ArcGIS Pro is installed on the machine, ensure that an ArcGIS Pro license is not checked out from ArcGIS Online.
If unsure that the ArcGIS Pro license is checked out on the machine, contact Esri Technical Support at 888-377-4575.

Umbenennen des Ordners "Esri"

  1. Öffnen Sie Windows Explorer.
  2. Navigieren Sie zu:
C:\Users\*username*\AppData\Roaming\ESRI
  1. Klicken Sie mit der rechten Maustaste auf den Ordner Esri, und wählen Sie Umbenennen aus. Benennen Sie den Ordner in "ESRI_old" um.

Bearbeiten des Registrierungsschlüssels

  1. Klicken Sie auf das Startmenü > Ausführen > geben Sie regedit ein.
  2. Blenden Sie im Fenster "Registrierungs-Editor" den Ordner HKEY_CURRENT_USER ein.
  3. Blenden Sie den Ordner Software ein.
  4. Benennen Sie den Ordner Esri in "Esri_old" um.
[O-Abbildung]
  1. Schließen Sie das Fenster Registrierungs-Editor.
  2. Starten Sie ArcMap.

Artikel-ID: 000012396

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln