PROBLEM

Die Bearbeitung von Versorgungsnetzdaten mit Attributregeln in ArcGIS Pro 2.7 ist nicht möglich

Last Published: April 7, 2021

Beschreibung

Beim Bearbeiten von Versorgungsnetzdaten mit Attributregeln in ArcGIS Pro 2.7 treten Fehler auf, und es wird gelegentlich die folgende Fehlermeldung zurückgegeben:

Error: Neue(s) Feature(s) konnte(n) nicht erstellt werden. Fehler beim Auswerten eines Arcade-Ausdrucks. [GlobalID: {00000000-0000-0000-0000-000000000000}, Arcade-Fehler: Allgemeiner Auswertungsfehler]
Eine der Fehlermeldungen, die möglicherweise beim Bearbeiten der Versorgungsnetzdaten mit Attributregeln zurückgegeben wird

Ursache

Im Abschnitt "Ausführung" der Ansicht "Attributregeln" in ArcGIS Pro 2.7 ist die Option "Von Anwendungsauswertung ausschließen" nicht aktiviert.

Lösung oder Problemumgehung

Gehen Sie wie folgt vor, um das Problem zu beheben.

Hinweis: Sofern der Utility Network Service ausgeführt wird, öffnen Sie ArcGIS Server Manager, und beenden Sie den Utility Network Service, bevor Sie mit dem folgenden Workflow fortfahren. Eine Anleitung hierzu finden Sie unter ArcGIS Server: Beenden eines Service in Manager.
  1. Öffnen Sie in ArcGIS Pro die Ansicht Attributregeln. Eine Anleitung hierzu finden Sie unter ArcGIS Pro: Öffnen der Ansicht "Attributregeln".
  2. Wählen Sie die Regel aus, und navigieren Sie zum Abschnitt Ausführung der Regeleigenschaften im Bereich "Details".
  3. Aktivieren Sie das Kontrollkästchen Von Anwendungsauswertung ausschließen, um die Bearbeitung der Versorgungsnetzdaten mit Attributregeln zu ermöglichen.
Abbildung der aktivierten Option
  1. Klicken Sie im oberen Menüband auf die Registerkarte Attributregeln, und klicken Sie zum Speichern der Änderungen auf Speichern.
Speichern der zum Aktivieren der Bearbeitung an den Regeleigenschaften vorgenommenen Änderungen
  1. Wiederholen Sie die Schritte 2 bis 4 für jede Feature-Class.
  2. Starten Sie den Service in ArcGIS Server Manager. Eine Anleitung hierzu finden Sie unter ArcGIS Server: Starten eines Service in Manager.
  3. ArcGIS Pro muss geschlossen und neu gestartet werden, damit die Änderungen wirksam werden.

Artikel-ID: 000025256

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln