PROBLEM

Herunterladen einer Datei von ArcGIS Hub nicht möglich

Last Published: December 9, 2021

Beschreibung

Beim Generieren oder Herunterladen einer Datei von ArcGIS Hub (z. B. eines Shapefile oder einer KML-Datei) tritt ein Fehler auf, und es wird die folgende Fehlermeldung angezeigt.

Error: Fehler beim Generieren der Datei
Der

Gelegentlich wird die Datei nicht vollständig erstellt bzw. nicht heruntergeladen. Dabei wird die folgende Warnmeldung angezeigt:

Warnung: Datei wird generiert Die Datei wird aktualisiert. Dieser Vorgang kann einige Zeit in Anspruch nehmen.
Die Dateigeneration wird nicht vollständig geladen, und es wird eine Warnmeldung angezeigt.

Ursache

  • Umfangreichere und komplexere Datasets können dazu führen, dass das Herunterladen sehr lange dauert oder insgesamt fehlschlägt.
  • Der räumliche Index des gehosteten Feature-Layers wurde nach dem Veröffentlichen in ArcGIS Online nicht ordnungsgemäß neu erstellt. Veraltete Indizes können zu einer schlechten Abfrage-Performance führen.

Lösung oder Problemumgehung

Verwenden Sie einen der folgenden Workarounds, um die Performance beim Generieren von Dateien zu verbessern und um zu verhindern, dass Downloads fehlschlagen.

Aktivieren der Option "Erstellung oder Aktualisierung von Features verfolgen" in ArcGIS Online

Wenn Sie die Option Erstellung oder Aktualisierung von Features verfolgen aktivieren, kann ArcGIS Hub erkennen, welche Features aktualisiert wurden. Eine Anleitung sowie weitere Informationen finden Sie unter ArcGIS Online: Änderungen durch andere zulassen.

Aktivieren der Option "Layer optimieren" in ArcGIS Online

Zur Verbesserung der Dateigenerierungszeit kann für die Layer die Option Layer optimieren in ArcGIS Hub aktiviert werden. Durch das Aktivieren dieser Option wird jedoch die Dateigröße des Feature-Layers erhöht. Weitere Schritte und Informationen finden Sie unter ArcGIS Online: Optimierte Darstellung komplexer Linien und Polygone.

Herunterladen der Datei als File-Geodatabase

Alternativ können große Dateien als File-Geodatabase heruntergeladen werden. Vorher muss jedoch die Option Anderen Benutzern erlauben, unterschiedliche Formate zu exportieren aktiviert werden. Weitere Schritte und Informationen finden Sie unter ArcGIS Hub: Aktivieren von File-Geodatabase-Downloads.

Reparieren des räumlichen Indexes der Layer

  1. Navigieren Sie in ArcGIS Online zur Registerkarte Inhalt.
  2. Klicken Sie auf den gehosteten Feature-Layer, um die Elementseite des gehosteten Feature-Layers zu öffnen.
  3. Aktivieren Sie auf der Registerkarte Einstellungen die Option Bearbeitung aktivieren.
Die Option
  1. Klicken Sie auf Indizes neu erstellen unter dem Abschnitt Räumliche Indizes verwalten.
Die Option
  1. Aktivieren Sie die Kontrollkästchen für die Feature-Layer, für die die räumlichen Indizes neu erstellt werden sollen, und klicken Sie auf Erneut erstellen.

Herunterladen einer zuvor erstellten Datei in ArcGIS Hub

Wenn eine aktualisierte Datei nicht erforderlich ist, kann eine ältere Dateiversion in ArcGIS Hub heruntergeladen werden. Zuvor erstellte Dateien müssen nicht neu generiert werden und können sofort heruntergeladen werden. Zum Herunterladen einer zuvor erstellen Datei klicken Sie auf das Dropdown-Menü Download-Optionen unter der gewünschten Datei, und klicken Sie auf Datei herunterladen, die am <Datum>, <Zeit> erstellt wurde.

Die Option zum Herunterladen einer zuvor erstellten Datei in ArcGIS Hub

Artikel-ID: 000026917

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln