PROBLEM

Das Löschen eines getrennten Elements in Portal for ArcGIS ist nicht möglich

Last Published: May 10, 2022

Beschreibung

Der Versuch, ein Element in Portal for ArcGIS zu löschen, schlägt fehl, wobei die folgende Fehlermeldung zurückgegeben wird:

Error: Das Element ist nicht vorhanden oder es kann nicht darauf zugegriffen werden. Fehler: 400
Die Fehlermeldung bei dem Versuch, ein verwaistes Element in Portal for ArcGIS zu löschen

Dieser Fehler wird bei dem Versuch zurückgegeben, ein getrenntes Element zu löschen, das im Verzeichnis des Portalinhalts nicht vorhanden ist.

Ursache

Wenn über Portal for ArcGIS ein Befehl zum Löschen ausgeführt wird, wird die Element-ID im Inhaltsspeicher des ArcGIS-Portalverzeichnisses mit der Element-ID in der internen Datenbank des Portals abgeglichen. Der Fehler tritt auf, wenn das Element von Portal for ArcGIS nicht im Inhaltsverzeichnis identifiziert werden kann.

Lösung oder Problemumgehung

  1. Melden Sie sich bei Portal for ArcGIS > Eigene Inhalte an.
  2. Öffnen Sie die Seite Elementdetails der zu löschenden Elemente.
  3. Notieren Sie sich die Element-ID aus der URL der getrennten Elemente.
Die Position des alphanumerischen Codes der Element-ID, die in Portal for ArcGIS gelöscht werden soll
  1. Navigieren Sie zu Eigene Inhalte, und öffnen Sie die Seite Elementdetails einer Webkarte, auf die zugegriffen werden kann.
  2. Notieren Sie sich die Element-ID aus der URL.
Die Position des alphanumerischen Codes der Element-ID einer funktionierenden Webkarte in Portal for ArcGIS
  1. Navigieren Sie zum Verzeichnis des Portalinhalts, und suchen Sie den Ordner, der der Element-ID der funktionierenden Webkarte entspricht.
Hinweis: Das Verzeichnis des Portalinhalts befindet sich in der Regel unter: <Portal for ArcGIS-Installationsverzeichnis>\arcgis\arcgisportal\content\items
  1. Kopieren Sie den Inhalt des Ordners.
  2. Erstellen Sie innerhalb des Verzeichnisses des Portalinhalts einen neuen Ordner, und geben Sie einen Namen an, der mit der zu löschenden Element-ID in Schritt 2 übereinstimmt. In diesem Beispiel lautet der Name des neu erstellten Ordners "e3eb35e9f944472c84dbdbad9dbad2cc".
  3. Fügen Sie den kopierten Inhalt der funktionierenden Webkarte in den neu erstellten Ordner ein.
  4. Navigieren Sie zu Eigene Inhalte, wählen Sie das Element aus, das gelöscht werden soll, und klicken Sie auf Löschen.
Hinweis: Wenn das Problem weiterhin auftritt, erstellen Sie den Portal for ArcGIS-Index neu, und löschen Sie das Element. Weitere Informationen finden Sie unter ArcGIS REST APIs: Reindex.

Artikel-ID: 000024798

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln