Beschreibung
Bei dem Versuch, ArcGIS Survey123 Connect eine neue Portal-Verbindung hinzuzufügen, wird die folgende Fehlermeldung zurückgegeben:
Error: "ERR_NAME_NOT_RESOLVED"
Ursache
Für diesen Fehler sind unter anderem folgende Ursachen möglich:
- Der Data Store befindet sich im Modus "READONLY". Daher kann der Data Store nicht validiert werden, da in diesem Modus keine Daten gesendet werden können. Der Fehler kann auftreten, wenn der verfügbare Speicherplatz für den Data Store auf dem Computer weniger als 1024 MB beträgt.
- Die JSON-Datei, die mit der Verbindung zwischen ArcGIS Survey123 Connect und Portal for ArcGIS verknüpft ist, ist beschädigt.
Lösung oder Problemumgehung
Führen Sie die Schritte unten aus, um das Problem zu beheben:
- Erhöhen Sie den dem Data Store zugewiesenen Speicherplatz, und ändern Sie bei Bedarf den Modus des Data Store auf "READWRITE". Eine Anleitung hierzu finden Sie unter Portal for ArcGIS: changedatastoremode.
- Validieren Sie den Data Store. Eine Anleitung hierzu finden Sie unter Portal for ArcGIS: Überprüfen des Data Store.
- Navigieren Sie zum folgenden Verzeichnis:
C:\Benutzer\<Benutzername>\ArcGIS\AppStudio\Settings
- Öffnen Sie die aktuellste JSON-Datei in einem Text-Editor, und lokalisieren Sie die Portal-URL im Feld portal/url.
- Legen Sie für das Feld portal/url in der JSON-Datei eine leere Zeichenfolge fest, damit das Feld mit der neuen Portal-URL ausgefüllt werden kann.
- Verbinden Sie ArcGIS Survey123 Connect erneut mit dem neuen Portal. Eine Anleitung hierzu finden Sie unter ArcGIS Survey123: Verwenden von Survey123 mit ArcGIS Enterprise.