PROBLEM

Aus Dropbox kann keine CSV-Datei als Layer zu ArcGIS Online-Webkarten hinzugefügt werden

Last Published: May 30, 2020

Beschreibung

Wenn in ArcGIS Online mit der Option "Layer aus Web hinzufügen" eine CSV-Datei aus Dropbox in einer Webkarte hinzugefügt wird, wird die folgende Fehlermeldung zurückgegeben:

Error: Der Layer wurde nicht erstellt, da keine Positionen gefunden werden konnten. Stellen Sie sicher, dass Ihre Daten gültige Positionsinformationen aufweisen.
Abbildung der Fehlermeldung

Ursache

Die aus Dropbox kopierte URL enthält den Abfrageparameter "dl=0", der eine Verknüpfung zu einer Vorschauseite der CSV-Datei in Dropbox herstellt. Dadurch ist es ArcGIS Online unmöglich, die CSV-Datei herunterzuladen und in der Webkarte anzuzeigen.

Lösung oder Problemumgehung

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben.
  1. Starten Sie die Webkarte in ArcGIS Online.
  2. Klicken Sie auf Hinzufügen Die Schaltfläche , und wählen Sie Layer aus Web hinzufügen im Dropdown-Menü aus.
  3. Fügen Sie im Fenster Layer aus Web hinzufügen die URL der aus Dropbox abgerufenen CSV-Datei ein.
  4. Ersetzen Sie den Abfrageparameter dl=0 durch dl=1, und klicken Sie auf Layer hinzufügen, wie in der folgenden Abbildung dargestellt.
Abbildung des Dialogfeldes
Die CSV-Datei aus Dropbox wird als Layer in der Webkarte hinzugefügt.
Abbildung einer Webkarte mit hinzugefügter CSV-Datei

Artikel-ID: 000023174

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln