PROBLEM

Problembehandlung bei der Einrichtung der verteilten Kollaboration zwischen ArcGIS Online und Portal for ArcGIS

Last Published: March 22, 2023

Beschreibung

Beim Einrichten der verteilten Kollaboration zwischen Portal for ArcGIS und ArcGIS Online treten häufig verschiedene Probleme auf. Ein Problem besteht darin, dass in der ArcGIS Online-Workstation der Status "Noch nicht beigetreten" angezeigt wird. Der Status in ArcGIS Online weist darauf hin, dass Portal for ArcGIS der Kollaboration noch nicht beigetreten ist. Inhalte können erst synchronisiert werden, wenn sowohl in Portal for ArcGIS als auch in ArcGIS Online der Status "Beigetreten" für die Kollaboration angezeigt wird. Überprüfen Sie die Protokolldatensätze von Portal for ArcGIS auf Ereignisse oder mit Ereignissen verbundene Fehler, um das Problem aufzuklären.

Nachfolgend sehen Sie ein Beispiel einer Meldung, die in den Protokollen des Portals angezeigt wird.

Collaboration invitation validation failed for Collaboration invitation validation completed. Existing collaboration with id 'xxxxxxxxxxxxxxxxxxxxxx' found. Invitation for this collaboration was already previously accepted. The certificate authority that issued the SSL certificate needs to be trusted by Portal before the invitation can be accepted.

Verwenden Sie die Seite "checkUrl.jsp", um zu ermitteln, ob Portal for ArcGIS mit ArcGIS Online kommunizieren kann. Navigieren Sie in einem Webbrowser zu der folgenden URL:

https://portal.domain.com/portal/sharing/checkUrl.jsp?url=https://www.arcgis.com

Wenn die unten beschriebene Meldung zurückgegeben wird, ist die Problembehandlung der Internetverbindungseinstellungen des Portals erforderlich.

{ "success": false, "error": {"message": "Unknown Exception"} }

Ursache

  • Die konfigurierten SSL-Zertifikatdetails von Portal for ArcGIS stimmen nicht mit den Zertifikatdetails von ArcGIS Online überein.
  • Es besteht keine Verbindung zwischen ArcGIS Online und Portal for ArcGIS.

Lösung oder Problemumgehung

Hinweis: Die folgenden Workarounds müssen vom IT-Personal der Organisation durchgeführt werden.

Vergleichen der Zertifikate von Portal for ArcGIS und ArcGIS Web Adaptor

Vergewissern Sie sich, dass das mit Portal for ArcGIS konfigurierte Zertifikat der Portal-URL entspricht, mit der die Kollaboration erstellt wurde.

  1. Überprüfen Sie die zum Erstellen der Kollaboration verwendete Portal-URL, indem Sie zu ArcGIS Online > Organisation > Einstellungen > Kollaborationen navigieren. Wählen Sie unter Name der Kollaboration die gewünschte Kollaboration aus, und klicken Sie auf Gäste anzeigen. Die URL wird unter URL aufgeführt.
  2. Überprüfen Sie das mit dem Portal konfigurierte Zertifikat.
    1. Navigieren Sie zum Portal-Administratorverzeichnis, und melden Sie sich an.
    2. Navigieren Sie zu Security > SSLCertificates.
    3. Ermitteln Sie das Zertifikat, das für Web Server SSL Certificate aufgeführt wird.
    4. Klicken Sie auf den Zertifikatsnamen, um die Seite Certificate Information zu öffnen. Überprüfen Sie die Zertifikatdetails.
    5. Vergewissern Sie sich, dass das Zertifikat für die Portal-URL, mit der die Kollaboration erstellt wurde, gültig ist.
  3. Überprüfen Sie im Internetinformationsdienste-Manager (IIS), dass das richtige Zertifikat an Port 433 für ArcGIS Web Adaptor gebunden ist und dass das Zertifikat für die Portal-URL, mit der die Kollaboration erstellt wurde, gültig ist.

Bestätigen der Verbindung zwischen Portal for ArcGIS und ArcGIS Online

Portal for ArcGIS benötigt für eine erfolgreiche Kollaboration ausgehenden Zugriff auf ArcGIS Online. Stellen Sie fest, ob zwischen dem Portal und ArcGIS Online eine Verbindung eingerichtet wurde.

  1. Melden Sie sich auf dem Portal-Computer mit dem Konto an, das zum Ausführen des Portal-Windows-Service verwendet wird.
  2. Öffnen Sie einen Webbrowser, und vergewissern Sie sich, dass Portal Zugriff auf ArcGIS Online hat.
  3. Überprüfen Sie das ArcGIS Online-Zertifikat, und stellen Sie sicher, dass die Zertifikatdetails beim Anzeigen über die Workstation mit dem ArcGIS Online-Zertifikat übereinstimmen.

Artikel-ID: 000020005

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln