HOW TO

Das Werkzeug "Validation and Repair" reagiert während der Deinstallation des Portal for ArcGIS-Patch nicht mehr, oder das Werkzeug stürzt ab

Last Published: July 29, 2024

Beschreibung

Beim Ausführen des Werkzeugs "Validation and Repair" für Portal for ArcGIS reagiert das Fenster des Werkzeugs nicht mehr oder das Werkzeug stürzt beim Deinstallieren von Patches ab. Die Überprüfung der Betriebssystemaktivität (BS) zeigt keine laufenden Hintergrundprozesse an.

Die folgenden Protokolle werden in den Protokollen der Windows-Ereignisanzeige entsprechend für jeden Absturz angezeigt:

Die Protokolle der Windows-Ereignisanzeige, die für jeden Absturz entsprechend angezeigt werden

In bestimmten Fällen wird die folgende Fehlermeldung im Fenster "Portal for ArcGIS 10.8.1 Validation and Repair" angezeigt:

Error:
There were issues uninstalling patches from your portal machine.
Die Fehlermeldung im Fenster des Werkzeugs "ArcGIS 10.8.1 Validation and Repair"

Beim Versuch, die Patches über die Microsoft Windows-Systemsteuerung zu deinstallieren, wird die folgende Fehlermeldung angezeigt:

Error: 
The feature you are trying to use is on a network resource that is unavailable.
Note: 
The patches uninstallation process for Portal for ArcGIS 10.8.1 or 10.9.1 taking a longer time is anticipated. Refer to Patches and Updates: Portal for ArcGIS Validation and Repair for more information.

Ursache

  • Die auf dem Computer installierte Antivirensoftware blockiert oder schränkt den Zugriff auf eine oder mehrere Patch-Dateien ein. Die Verbindung zu den Patch-Dateien kann durch vorab festgelegte Sicherheitsregeln der Organisation blockiert sein.
  • Das Werkzeug "Validation and Repair" kann nicht nach der ursprünglichen Setup-Datei für Portal for ArcGIS suchen.

Lösung oder Problemumgehung

Je nach Situation können die nachfolgend beschriebenen Workarounds angewendet werden.

Deaktivieren der Antivirensoftware und Beenden der verbleibenden Tasks

Wenden Sie sich an die IT-Abteilung, um die Antivirensoftware zu deaktivieren, und führen Sie das Werkzeug "Validation and Repair" erneut aus. Wenn das Problem dadurch nicht behoben wird, führen Sie die folgenden Schritte aus, um Tasks im Fenster "Task-Manager" zu beenden, und führen Sie das Werkzeug "Validation and Repair" erneut aus.

  1. Drücken Sie die Tasten Windows + X, und wählen Sie Task-Manager aus dem Menü aus. Das Fenster Task-Manager wird geöffnet.
  2. Wählen Sie auf der Registerkarte Prozesse die Option Validation and Repair aus, und klicken Sie auf Task beenden.
  3. Wählen Sie 7za.exe aus, und klicken Sie auf Task beenden.
  4. Schließen Sie das Fenster Task-Manager.
  5. Führen Sie das Werkzeug Validation and Repair aus.

Ausführen des Werkzeugs "Validation and Repair" über die Eingabeaufforderung

Führen Sie die folgenden Schritte aus, wenn das Deaktivieren der Antivirensoftware keine Option ist.

  1. Suchen Sie im Windows-Suchfeld auf der Taskleiste nach Windows-Eingabeaufforderung, klicken Sie mit der rechten Maustaste darauf, und wählen Sie dann Als Administrator ausführen aus.
  2. Führen Sie im Fenster Administrator: Eingabeaufforderung den folgenden Befehl aus, um das Verzeichnis in der Eingabeaufforderung in das Verzeichnis zu ändern, in dem sich das Werkzeug "Validation and Repair" befindet.
C:/<ArcGIS Server installation directory>\<download folder>
  1. Führen Sie das Werkzeug Validation and Repair aus, indem Sie den Namen des Werkzeugs in die Befehlszeile eingeben.
ArcGIS-PFA-1081-ValidationRepair.exe
Der Befehl im Windows-Fenster "Administrator: Eingabeaufforderung"

Extrahieren der Setup-Datei des Portals an den richtigen Speicherort

Um die Fehlermeldung zu beheben, extrahieren Sie die Setup-Datei des Portals, oder laden Sie sie in den Pfad herunter, der in der Eigenschaft "SourceDir" in der Windows-Registrierung definiert ist. Der Standardpfad für die extrahierte Installationsdatei lautet:

C:\Users\<user profile ID>\Documents\ArcGIS 10.8.1\PortalForArcGIS\SetupFiles
  1. Navigieren Sie zu dem Speicherort der Setup-Datei für Portal for ArcGIS:
    1. Suchen Sie im Windows-Suchfeld auf der Taskleiste nach Registrierungs-Editor, und klicken Sie darauf.
    2. Kopieren Sie im Fenster Registrierungs-Editor den folgenden Dateipfad in das Feld Suchen.
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\Portal for ArcGIS
Das Feld "Suchen" im Fenster des Registrierungs-Editors
  1. Prüfen Sie den Dateipfad, der in der Spalte Daten der Eigenschaft SourceDir enthalten ist.
Der Portal for ArcGIS-Dateipfad in der Spalte "Daten" der Eigenschaft "SourceDir"
  1. Laden Sie die Setup-Datei für Portal for ArcGIS herunter, und führen Sie die Datei aus, um sie in den Ordner "SourceDir" zu extrahieren. Weitere Informationen finden Sie unter How To: Herunterladen und Installieren von Software von My Esri.
Warning:
Do not run the setup file after the extraction is completed. Doing so may result in overwriting the existing deployment.
  1. Führen Sie das Werkzeug Validation and Repair aus.

Artikel-ID: 000032123

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln