PROBLEM

Die externe Auswahlliste in der ArcGIS Survey123-Web-App ist nicht verfügbar

Last Published: October 20, 2022

Beschreibung

Die Verwendung einer externen Auswahlliste ist gut geeignet, wenn die Auswahlliste außerhalb von ArcGIS Survery123 verwaltet wird oder sehr groß ist. Manchmal ist die externe Auswahlliste allerdings nicht verfügbar, wenn der Survey in der mobilen Survey123-App angezeigt wird, obwohl sie über ArcGIS Survey123 Connect und die mobile Survey123-App zugänglich ist. Je nach Fehlerursache wird eine der folgenden Meldungen zurückgegeben:

Error: Formular wird initialisiert... TypeError: NULL-Eigenschaft von "textContent" kann nicht gelesen werden.
Fehlermeldung, die bei der Anzeige des Survey in der mobilen ArcGIS Survey123-App zurückgegeben wird
Error: Formular wird initialisiert... CSV-Spaltenüberschrift "field_name" kann nicht in ein gültiges XML-Element umgewandelt werden.
Fehlermeldung, die bei der Anzeige des Survey in der mobilen ArcGIS Survey123-App zurückgegeben wird
Error: Formular wird initialisiert... Laden von Daten von <data_source> fehlgeschlagen
Fehlermeldung, die bei der Anzeige des Survey in der mobilen ArcGIS Survey123-App zurückgegeben wird

Ursache

Für dieses Problem sind die folgenden Ursachen bekannt:

  • Die Feldnamen in der referenzierten CSV-Datei enthalten Leerzeichen, Sonderzeichen oder Großbuchstaben.
  • In der CSV-Datei fehlt die Spalte "name" oder "label".
  • Die CSV-Datei enthält leere Spalten.
  • Der Name der CSV-Datei stimmt nicht mit dem Namen der Auswahlliste im Fragentyp "select_one_from_file" oder "select_multiple_from_file" im XLSForm des Survey überein.

Lösung oder Problemumgehung

Verwenden Sie je nach Ursache des Problems eine der folgenden Optionen:

Vergewissern Sie sich, dass die Feldnamen keine Sonderzeichen, Großbuchstaben oder Leerzeichen enthalten.

  • Löschen Sie Sonderzeichen wie Schrägstriche (/) aus den Feldnamen.
  • Verwenden Sie Klein- statt Großbuchstaben.
  • Ersetzen Sie Leerzeichen in den Feldnamen durch Unterstriche.
In der CSV-Datei müssen die Spalten "name" und "label" und dürfen keine leeren Spalten enthalten sein.
  • Die CSV-Datei muss die Spalten "name" und "label" enthalten.
Spalten
  • Löschen Sie leere Spalten aus der CSV-Datei.

Vergewissern Sie sich, dass der Name der Auswahlliste im Fragentyp mit dem Namen der CSV-Datei übereinstimmt.

Vergewissern Sie sich, dass im XLSForm in ArcGIS Survey123 Connect der Name der externen Auswahlliste im Fragentyp "select_one_from_file" oder "select_multiple_from_file" mit der referenzierten CSV-Datei übereinstimmt. Bei CSV-Dateinamen wird die Groß-/Kleinschreibung beachtet, und sie dürfen keine Leerzeichen enthalten.

Der Name der externen Auswahlliste in der Frage stimmt mit der referenzierten CSV-Datei überein.

Die nachfolgende Abbildung zeigt die in der mobilen ArcGIS Survey123-App verfügbare externe Auswahlliste.

Die externe Auswahlliste in der mobilen ArcGIS Survey123-App bei ordnungsgemäßer Konfiguration der referenzierten CSV-Datei in ArcGIS Survey123 Connect.

Artikel-ID: 000025209

Benachrichtigungen erhalten und Lösungen für neue oder häufige Probleme finden

Unser neuer KI-Chatbot stellt zusammengefasste Antworten und Videolösungen für Sie bereit.

Esri Support App herunterladen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Esri Support App herunterladen

Zu Download-Optionen wechseln