Beschreibung
Eine vorhandene Standard-File-Geodatabase in ArcGIS Pro ist leer, obwohl sie Datasets enthalten sollte. In der folgenden Abbildung wird eine leere aktuelle Geodatabase mit Features angezeigt, die im Bereich "Katalog" fehlen.
Ursache
- Die File-Geodatabase wurde aus dem Projektordner verschoben.
- Die File-Geodatabase wurde im Datei-Explorer umbenannt.
In beiden Szenarien generiert ArcGIS Pro automatisch eine neue, leere Standard-File-Geodatabase, wie es in jedem ArcGIS Pro-Projekt erforderlich ist.
Lösung oder Problemumgehung
Verschieben Sie die ursprüngliche File-Geodatabase in den Home-Ordner des Projekts
- Öffnen Sie das ArcGIS Pro-Projekt. Klicken Sie im Bereich Katalog mit der rechten Maustaste auf die File-Geodatabase, und klicken Sie auf Im Datei-Explorer anzeigen.
- Schließen Sie ArcGIS Pro.
- Suchen Sie im Fenster Datei-Explorer die ursprüngliche File-Geodatabase, kopieren Sie sie, und fügen Sie sie in den Home-Ordner des Projekts ein.
- Klicken Sie im Fenster Dateien ersetzen oder überspringen auf Dateien im Ziel ersetzen.
- Öffnen Sie das Projekt erneut in ArcGIS Pro.
Benennen Sie die File-Geodatabase in den Standardnamen um
- Öffnen Sie das ArcGIS Pro-Projekt. Klicken Sie im Bereich Katalog mit der rechten Maustaste auf den Ordner der File-Geodatabase, und klicken Sie auf Im Datei-Explorer anzeigen.
- Schließen Sie ArcGIS Pro.
- Löschen Sie den automatisch generierten File-Geodatabase-Ordner im Datei-Explorer.
- Benennen Sie die File-Geodatabase in den Standardnamen um. In diesem Beispiel wurde der Name der ursprünglichen File-Geodatabase von "Change_test5_default gdb.gdb" in "test5_default gdb.gdb" geändert.
- Öffnen Sie das Projekt erneut in ArcGIS Pro.
Die folgende Abbildung zeigt das Dataset wie erwartet unter der Standard-File-Geodatabase im Bereich "Katalog".